summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sourceforge.net>2006-05-18 19:34:47 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2006-05-18 19:34:47 +0000
commit957ad05fa6c44ef11181ffcaee1ccc4a03e5cb30 (patch)
tree22fcffeca841381e9e1f59141e378c8547f7e068 /configure.ac
parentfb76f0b1b59c1862521c174a57786b4e9373f415 (diff)
downloadgst-plugins-bad-957ad05fa6c44ef11181ffcaee1ccc4a03e5cb30.tar.gz
gst-plugins-bad-957ad05fa6c44ef11181ffcaee1ccc4a03e5cb30.tar.bz2
gst-plugins-bad-957ad05fa6c44ef11181ffcaee1ccc4a03e5cb30.zip
configure.ac: Check for X11
Original commit message from CVS: * configure.ac: Check for X11 * sys/v4l2/gstv4l2object.c: (gst_v4l2_class_probe_devices): * sys/v4l2/gstv4l2object.h: * sys/v4l2/gstv4l2src.c: (gst_v4l2src_iface_supported): * sys/v4l2/gstv4l2src.h: * sys/v4l2/gstv4l2xoverlay.c: (gst_v4l2_xoverlay_open): * sys/v4l2/gstv4l2xoverlay.h: Code cleanups, fix debug macros
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index edec3d7c..7fae772a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -204,6 +204,36 @@ GST_CHECK_FEATURE(OPENGL, [Open GL], glsink, [
CPPFLAGS="$save_CPPFLAGS"
LIBS="$save_LIBS"
+dnl Check for X11
+translit(dnm, m, l) AM_CONDITIONAL(USE_X, true)
+GST_CHECK_FEATURE(X, [X libraries and plugins],
+ [ximagesrc], [
+ AC_PATH_XTRA
+
+ dnl now try to find the HEADER
+ ac_cflags_save="$CFLAGS"
+ ac_cppflags_save="$CPPFLAGS"
+ CFLAGS="$CFLAGS $X_CFLAGS"
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
+ AC_CHECK_HEADER(X11/X.h, HAVE_X="yes", HAVE_X="no")
+
+ if test "x$HAVE_X" = "xno"
+ then
+ AC_MSG_NOTICE([cannot find X11 development files])
+ else
+ dnl this is much more than we want
+ X_LIBS="$X_LIBS $X_PRE_LIBS $X_EXTRA_LIBS"
+ dnl AC_PATH_XTRA only defines the path needed to find the X libs,
+ dnl it does not add the libs; therefore we add them here
+ X_LIBS="$X_LIBS -lX11"
+ AC_SUBST(X_CFLAGS)
+ AC_SUBST(X_LIBS)
+ fi
+ AC_SUBST(HAVE_X)
+ CFLAGS="$ac_cflags_save"
+ CPPFLAGS="$ac_cppflags_save"
+])
+
dnl *** Video 4 Linux 2 ***
dnl for information about the header/define, see sys/v4l2/gstv4l2element.h
dnl renamed to GST_V4L2 because of some conflict with kernel headers