summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-12-21 18:44:34 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-12-21 18:44:34 +0000
commit967aca777eb145764e4c309901f88efdf20283e1 (patch)
tree86a2aaf15c68e9bb484ff288b22dac135b48dc82 /configure.ac
parenta17fd964ba612f40c96529997ed79abdc5a7427d (diff)
downloadgst-plugins-bad-967aca777eb145764e4c309901f88efdf20283e1.tar.gz
gst-plugins-bad-967aca777eb145764e4c309901f88efdf20283e1.tar.bz2
gst-plugins-bad-967aca777eb145764e4c309901f88efdf20283e1.zip
configure.ac: Improve mpeg2enc detection. This is for distributions that do ship mjpegtools, but without mpeg2enc. Al...
Original commit message from CVS: 2003-12-21 Ronald Bultje <rbultje@ronald.bitfreak.net> * configure.ac: Improve mpeg2enc detection. This is for distributions that do ship mjpegtools, but without mpeg2enc. Also does object check for might there ever be ABI incompatibility. * ext/mpeg2enc/gstmpeg2enc.cc: Add Andrew as second maintainer (he's helping me), and also add an error if no caps was set. This happens if I pull before capsnego and that's something I should solve sometime else. * gst/matroska/matroska-demux.c: (gst_matroska_demux_parse_blockgroup): Fix time parsing. * gst/matroska/matroska-mux.c: (gst_matroska_mux_audio_pad_link), (gst_matroska_mux_track_header): Add caps to templates. * gst/mpegaudioparse/gstmpegaudioparse.c: (mp3_sink_factory): Add mpegversion=1 to prevent confusion with MPEG/AAC. * gst/mpegstream/gstmpegdemux.c: Remove layer since it causes warnings about unfixed caps. * gst/videotestsrc/gstvideotestsrc.c: (gst_videotestsrc_get): Fix obvious typo (we error out if caps were set, we should of course error out if *no* caps were set). * sys/oss/gstosselement.c: (gst_osselement_convert): Fix format conversion, we confused bits/bytes. * sys/oss/gstosselement.h: Improve documentation for 'bps'. * sys/v4l/TODO: Remove stuff about plugins that need removing - this was done ages ago. * sys/v4l/gstv4lmjpegsrc.c: (gst_v4lmjpegsrc_init), (gst_v4lmjpegsrc_src_convert), (gst_v4lmjpegsrc_src_query): * sys/v4l/gstv4lsrc.c: (gst_v4lsrc_init), (gst_v4lsrc_src_convert), (gst_v4lsrc_src_query): * sys/v4l2/gstv4l2src.c: (gst_v4l2src_init), (gst_v4l2src_src_convert), (gst_v4l2src_src_query): Add get_query_types(), get_formats() and query() functions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac46
1 files changed, 41 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 2557072a..6055d3b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1076,16 +1076,52 @@ GST_CHECK_FEATURE(MPEG2DEC, [mpeg2dec], mpeg2dec, [
dnl *** mpeg2enc ***
translit(dnm, m, l) AM_CONDITIONAL(USE_MPEG2ENC, true)
GST_CHECK_FEATURE(MPEG2ENC, [mpeg2enc], mpeg2enc, [
- PKG_CHECK_MODULES(MPEG2ENC, mjpegtools >= 1.6.1.92,
- HAVE_MPEG2ENC="yes", HAVE_MPEG2ENC="no")
- MPEG2ENC_LIBS="$MPEG2ENC_LIBS -lmpeg2encpp"
- AC_SUBST(MPEG2ENC_CFLAGS)
- AC_SUBST(MPEG2ENC_LIBS)
+ HAVE_MPEG2ENC="no"
+ dnl we require a c++ compiler for this one
+ if [ test x$HAVE_CXX = xyes ]; then
+ dnl libmpeg2enc was first included in mjpegtools-1.6.2-rc3 (1.6.1.92)
+ dnl since many distros include mjpegtools specifically without mplex
+ dnl and mpeg2enc, we check for mpeg2enc on its own, too.
+ PKG_CHECK_MODULES(MPEG2ENC, mjpegtools >= 1.6.1.92, [
+ dnl switch over to c++ to test things
+ AC_LANG_CPLUSPLUS
+ OLD_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $MPEG2ENC_CFLAGS"
+ AC_CHECK_HEADER(mpeg2encoder.hh, [
+ MPEG2ENC_LIBS="$MPEG2ENC_LIBS -lmpeg2encpp -lm -lpthread"
+ OLD_LIBS="$LIBS"
+ LIBS="$LIBS $MPEG2ENC_LIBS"
+ AC_MSG_CHECKING([for valid mpeg2enc objects])
+ AC_TRY_RUN([
+#include <mpeg2encoder.hh>
+#include <mpeg2encoptions.hh>
+
+int
+main (int argc,
+ char *argv[])
+{
+ MPEG2EncOptions *options = new MPEG2EncOptions ();
+ MPEG2Encoder encoder (*options);
+ return 0;
+}
+ ],[
+ HAVE_MPEG2ENC="yes"
+ AC_SUBST(MPEG2ENC_CFLAGS)
+ AC_SUBST(MPEG2ENC_LIBS)
+ AC_MSG_RESULT(yes)
+ ], AC_MSG_RESULT(no))
+ LIBS="$OLD_LIBS"
+ ])
+ CPPFLAGS="$OLD_CPPFLAGS"
+ AC_LANG_C
+ ])
+ fi
])
dnl *** mplex ***
translit(dnm, m, l) AM_CONDITIONAL(USE_MPLEX, true)
GST_CHECK_FEATURE(MPLEX, [mplex], mplex, [HAVE_MPLEX=$HAVE_CXX])
+])
dnl *** pango ***
translit(dnm, m, l) AM_CONDITIONAL(USE_PANGO, true)