summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Schaller <uraeus@gnome.org>2005-05-06 19:11:14 +0000
committerChristian Schaller <uraeus@gnome.org>2005-05-06 19:11:14 +0000
commitd0556a1534b491e0bf7c420ae4fed0cd79d5a955 (patch)
treeab51b6c7594e46067279c8dde2e43b0a3bae1eaa /configure.ac
parent871e333202fb6e17ea2d3e35bbb65c24ca07d11a (diff)
downloadgst-plugins-bad-d0556a1534b491e0bf7c420ae4fed0cd79d5a955.tar.gz
gst-plugins-bad-d0556a1534b491e0bf7c420ae4fed0cd79d5a955.tar.bz2
gst-plugins-bad-d0556a1534b491e0bf7c420ae4fed0cd79d5a955.zip
some sidplay fixoring
Original commit message from CVS: some sidplay fixoring
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 9 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index d3d97381..f2d77f92 100644
--- a/configure.ac
+++ b/configure.ac
@@ -242,6 +242,7 @@ if test "x$HAVE_GST_BASE" = "xno"; then
fi
AC_SUBST(GST_BASE_LIBS)
+AC_SUBST(GST_BASE_CFLAGS)
dnl check for gstreamer-interfaces; uinstalled is selected preferentially
PKG_CHECK_MODULES(GST_INTERFACES, gstreamer-interfaces-$GST_MAJORMINOR >= $GST_REQ,
@@ -252,6 +253,7 @@ if test "x$HAVE_GST_INTERFACES" = "xno"; then
fi
AC_SUBST(GST_INTERFACES_LIBS)
+AC_SUBST(GST_INTERFACES_CFLAGS)
dnl check for gstreamer-interfaces; uinstalled is selected preferentially
PKG_CHECK_MODULES(GST_PLUGINS_LIBS, gstreamer-libs-$GST_MAJORMINOR >= $GST_REQ,
@@ -262,7 +264,7 @@ if test "x$HAVE_GST_PLUGINS" = "xno"; then
fi
AC_SUBST(GST_PLUGINS_LIBS)
-
+AC_SUBST(GST_PLUGINS_CFLAGS)
dnl Determine endianness
AC_C_BIGENDIAN
@@ -305,8 +307,7 @@ dnl these are all the gst plug-ins, compilable without additional libs
GST_PLUGINS_ALL="\
videofilter \
effectv \
- law \
- sidplay"
+ law"
dnl see if we can build C++ plug-ins
if test "x$HAVE_CXX" = "xyes"; then
@@ -359,6 +360,11 @@ dnl ])
dnl ])
dnl ])
+dnl ###########################
+dnl # Configure external libs #
+dnl ###########################
+
+
dnl *** sidplay : works with libsidplay 1.36.x (not 2.x.x) ***
translit(dnm, m, l) AM_CONDITIONAL(USE_SIDPLAY, true)
GST_CHECK_FEATURE(SIDPLAY, [sidplay plug-in], sidplay, [
@@ -389,10 +395,6 @@ AC_SUBST(MAD_LIBS)
AC_SUBST(GST_LIBS)
AC_SUBST(GST_CFLAGS)
-dnl ###########################
-dnl # Configure external libs #
-dnl ###########################
-
dnl ############################
dnl # Set up some more defines #
dnl ############################