summaryrefslogtreecommitdiffstats
path: root/examples/gob/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2002-01-20 01:49:15 +0000
committerBastien Nocera <hadess@hadess.net>2002-01-20 01:49:15 +0000
commit8753236b55fe78ff5ac5daf0bbe9edbb5d5f57d9 (patch)
tree2c2eb82b010dc7131494e86d94aceea8cdca7e34 /examples/gob/Makefile.am
parent2cde2cdd8d0ac60d146af330ee0daffc5124cfec (diff)
downloadgst-plugins-bad-8753236b55fe78ff5ac5daf0bbe9edbb5d5f57d9.tar.gz
gst-plugins-bad-8753236b55fe78ff5ac5daf0bbe9edbb5d5f57d9.tar.bz2
gst-plugins-bad-8753236b55fe78ff5ac5daf0bbe9edbb5d5f57d9.zip
- added gob example plugin
Original commit message from CVS: - added gob example plugin
Diffstat (limited to 'examples/gob/Makefile.am')
-rw-r--r--examples/gob/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/gob/Makefile.am b/examples/gob/Makefile.am
new file mode 100644
index 00000000..bd0b916e
--- /dev/null
+++ b/examples/gob/Makefile.am
@@ -0,0 +1,21 @@
+
+plugindir = $(libdir)/gst
+
+plugin_LTLIBRARIES = libgstidentity2.la
+
+GOB_FILES_ID = gst-identity2.c gst-identity2.h gst-identity2-private.h
+
+BUILT_SOURCES = \
+ $(GOB_FILES_ID)
+
+libgstidentity2_la_SOURCES = gst-identity2.gob $(GOB_FILES_ID)
+libgstidentity2_la_CFLAGS = $(GST_CFLAGS)
+libgstidentity2_la_LIBADD = $(GST_LIBS)
+
+%.c %.h %-private.h: %.gob
+ gob $<
+
+CLEANFILES = $(GOB_FILES_ID)
+
+dist-hook:
+ cd $(distdir); rm -f $(CLEANFILES)