summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2001-12-26 06:49:47 +0000
committerAndy Wingo <wingo@pobox.com>2001-12-26 06:49:47 +0000
commit21de09a438bd3858bd47705cbfbcb7562c2fbe6b (patch)
tree548a3a23deb5c97cbf356d076e9829fbad84d3d7 /ext/Makefile.am
parent31bd0ef9c4765eb4b4caa65b18afa6935b6c4633 (diff)
downloadgst-plugins-bad-21de09a438bd3858bd47705cbfbcb7562c2fbe6b.tar.gz
gst-plugins-bad-21de09a438bd3858bd47705cbfbcb7562c2fbe6b.tar.bz2
gst-plugins-bad-21de09a438bd3858bd47705cbfbcb7562c2fbe6b.zip
muahahahaha. gstreamer-compprep initializes every plugin so it's a good way of figuring out plugin issues. it spits o...
Original commit message from CVS: muahahahaha. gstreamer-compprep initializes every plugin so it's a good way of figuring out plugin issues. it spits out no more errors now.
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am17
1 files changed, 12 insertions, 5 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 39ff5185..3ebdc5aa 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -160,6 +160,12 @@ else
SHOUT_DIR=
endif
+if USE_SMOOTHWAVE
+SMOOTHWAVE_DIR=smoothwave
+else
+SMOOTHWAVE_DIR=
+endif
+
if USE_VORBIS
VORBIS_DIR=vorbis
else
@@ -176,12 +182,13 @@ SUBDIRS=$(A52_DIR) $(AALIB_DIR) $(ALSA_DIR) \
$(ARTS_DIR) $(ARTSC_DIR) $(AUDIOFILE_DIR) \
$(AVIFILE_DIR) $(CDPARANOIA_DIR) $(DV_DIR) $(DVDREAD_DIR) $(ESD_DIR) \
$(FESTIVAL_DIR) $(FLAC_DIR) $(GNOMEVFS_DIR) $(GSM_DIR) $(HERMES_DIR) \
- $(HTTP_DIR) $(JPEG_DIR) $(LAME_DIR) $(MAD_DIR) \
- $(MIKMOD_DIR) $(MPEG2DEC_DIR) $(OPENQUICKTIME_DIR) \
- $(RAW1394_DIR) $(RTP_DIR) $(SDL_DIR) $(SHOUT_DIR) $(VORBIS_DIR) \
- $(XMMS_DIR)
+ $(HTTP_DIR) $(JPEG_DIR) $(LAME_DIR) $(MAD_DIR) $(MIKMOD_DIR) $(MPEG2DEC_DIR) \
+ $(OPENQUICKTIME_DIR) $(RTP_DIR) $(SDL_DIR) $(SHOUT_DIR) \
+ $(SMOOTHWAVE_DIR) $(VORBIS_DIR) $(XMMS_DIR)
DIST_SUBDIRS=a52 aalib alsa arts artsd avifile audiofile cdparanoia \
dv dvdread esd \
+ festival flac gnomevfs gsm hermes http jpeg lame mad mikmod mpeg2dec \
+ openquicktime rtp sdl shout smoothwave vorbis xmms
festival flac gnomevfs gsm hermes http jpeg ladspa lame mad mikmod mpeg2dec \
- openquicktime raw1394 rtp sdl shout sidplay vorbis xmms
+ openquicktime raw1394 rtp sdl shout sidplay smoothwave vorbis xmms