summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-12-11 21:07:25 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-12-11 21:07:25 +0000
commitaa9969dbcfca36106b6c9a37554221ecd621afd0 (patch)
treef33bca1153cf671732c60d901be37d55371c6cae /ext/Makefile.am
parent1c1767f82e5291dc0e49bb3283addde24184fcb4 (diff)
downloadgst-plugins-bad-aa9969dbcfca36106b6c9a37554221ecd621afd0.tar.gz
gst-plugins-bad-aa9969dbcfca36106b6c9a37554221ecd621afd0.tar.bz2
gst-plugins-bad-aa9969dbcfca36106b6c9a37554221ecd621afd0.zip
This is a first attempt at a wrapper for the lib'ified mpeg2enc of mjpegtools. Currently, there's a few release candi...
Original commit message from CVS: This is a first attempt at a wrapper for the lib'ified mpeg2enc of mjpegtools. Currently, there's a few release candidates for mjpegtools-1.6.2 available, but no stable version yet. I've made 4 small subclasses to wrap input, output, options and generic encoding model. The last .cc file is the GStreamer plugin element. Note that it doesn't actually work yet, I'm doing something wrong with header parsing and Andrew asked me to commit so he could help debugging that. Apart from that, we should soon be able to make top-quality MPEG encodes! :). mpeg2enc licensing is tricky, btw, I don't even want to start discussing that...
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index a26660d7..cdcfefe7 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -190,6 +190,12 @@ else
MPEG2DEC_DIR=
endif
+if USE_MPEG2ENC
+MPEG2ENC_DIR=mpeg2enc
+else
+MPEG2ENC_DIR=
+endif
+
if USE_MPLEX
MPLEX_DIR=mplex
else
@@ -318,6 +324,7 @@ SUBDIRS=\
$(MAS_DIR) \
$(MIKMOD_DIR) \
$(MPEG2DEC_DIR) \
+ $(MPEG2ENC_DIR) \
$(MPLEX_DIR) \
$(OGG_DIR) \
$(PANGO_DIR) \
@@ -367,6 +374,7 @@ DIST_SUBDIRS=\
mad \
mikmod \
mpeg2dec \
+ mpeg2enc \
mplex \
ogg \
pango \