summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorChris Lee <clee@kde.org>2006-07-23 11:52:34 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-07-23 11:52:34 +0000
commitb7f35a1240ff5ff5ccdfceb4730242f1714d9a18 (patch)
tree59a1a9842015ee2c1b01f50b33a10cb648e0606e /ext/Makefile.am
parentc8e459496b315ada563c65c0703e574b5913e849 (diff)
downloadgst-plugins-bad-b7f35a1240ff5ff5ccdfceb4730242f1714d9a18.tar.gz
gst-plugins-bad-b7f35a1240ff5ff5ccdfceb4730242f1714d9a18.tar.bz2
gst-plugins-bad-b7f35a1240ff5ff5ccdfceb4730242f1714d9a18.zip
Add libopenspc-based SPC decoder element (#348220).
Original commit message from CVS: Patch by: Chris Lee <clee at kde org> * configure.ac: * ext/Makefile.am: * ext/spc/Makefile.am: * ext/spc/gstspc.c: (spc_negotiate), (gst_spc_dec_base_init), (gst_spc_dec_class_init), (gst_spc_dec_init), (gst_spc_dec_chain), (gst_spc_dec_sink_event), (gst_spc_dec_src_event), (gst_spc_dec_src_query), (spc_play), (spc_setup), (gst_spc_dec_change_state), (plugin_init): * ext/spc/gstspc.h: Add libopenspc-based SPC decoder element (#348220).
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 42765f11..46d87baa 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -202,6 +202,12 @@ else
SOUNDTOUCH_DIR=
endif
+if USE_SPC
+SDL_DIR=spc
+else
+SDL_DIR=
+endif
+
if USE_SWFDEC
SWFDEC_DIR=swfdec
else
@@ -267,6 +273,7 @@ SUBDIRS=\
$(SMOOTHWAVE_DIR) \
$(SNDFILE_DIR) \
$(SOUNDTOUCH_DIR) \
+ $(SPC_DIR) \
$(SWFDEC_DIR) \
$(TARKIN_DIR) \
$(THEORA_DIR) \
@@ -291,8 +298,9 @@ DIST_SUBDIRS= \
musicbrainz \
neon \
sdl \
- swfdec \
soundtouch \
+ spc \
+ swfdec \
theora \
wavpack \
xvid