summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2001-12-23 15:24:07 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2001-12-23 15:24:07 +0000
commitba961327f3ea65e5fbe137b7357f21345c2b6e8e (patch)
tree4824e1b7fd7d2179c2a7dbd78a372473e47f6edd /ext/Makefile.am
parent34a42c54017619a7fab7a2dc3e0137e2e86d498f (diff)
downloadgst-plugins-bad-ba961327f3ea65e5fbe137b7357f21345c2b6e8e.tar.gz
gst-plugins-bad-ba961327f3ea65e5fbe137b7357f21345c2b6e8e.tar.bz2
gst-plugins-bad-ba961327f3ea65e5fbe137b7357f21345c2b6e8e.zip
added jpeg and shout (icecastsend has been renamed to shout, there are other libs that do icecast too)
Original commit message from CVS: added jpeg and shout (icecastsend has been renamed to shout, there are other libs that do icecast too)
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index e981f57f..8a69f2c2 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -76,6 +76,13 @@ else
LAME_DIR=
endif
+if USE_JPEG
+JPEG_DIR=jpeg
+else
+JPEG_DIR=
+endif
+
+
if USE_MAD
MAD_DIR=mad
else
@@ -94,6 +101,12 @@ else
SDL_DIR=
endif
+if USE_SHOUT
+SHOUT_DIR=shout
+else
+SHOUT_DIR=
+endif
+
if USE_VORBIS
VORBIS_DIR=vorbis
else
@@ -103,8 +116,8 @@ endif
SUBDIRS=$(A52_DIR) $(AALIB_DIR) $(ALSA_DIR) $(AUDIOFILE_DIR) \
$(AVIFILE_DIR) $(CDPARANOIA_DIR) $(DVDREAD_DIR) $(ESD_DIR) \
$(FESTIVAL_DIR) $(FLAC_DIR) $(GSM_DIR) $(HERMES_DIR) \
- $(LAME_DIR) $(MAD_DIR) $(MPEG2DEC_DIR) \
- $(SDL_DIR) $(VORBIS_DIR)
+ $(JPEG_DIR) $(LAME_DIR) $(MAD_DIR) $(MPEG2DEC_DIR) \
+ $(SDL_DIR) $(SHOUT_DIR) $(VORBIS_DIR)
DIST_SUBDIRS=a52 aalib alsa avifile audiofile cdparanoia dvdread esd \
- festival flac gsm hermes lame mad mpeg2dec sdl vorbis
+ festival flac gsm hermes jpeg lame mad mpeg2dec sdl shout vorbis