summaryrefslogtreecommitdiffstats
path: root/ext/directfb/Makefile.am
diff options
context:
space:
mode:
authorJulien Moutte <julien@moutte.net>2005-11-05 23:36:20 +0000
committerJulien Moutte <julien@moutte.net>2005-11-05 23:36:20 +0000
commit72e3851f87ed6e0f07ba74afb7e260f5bfe8def8 (patch)
treede44c4b366f5f7c303466228f800a91a9db7634d /ext/directfb/Makefile.am
parent0adb034b32d93e761f38dae2e4485c1095e1a786 (diff)
downloadgst-plugins-bad-72e3851f87ed6e0f07ba74afb7e260f5bfe8def8.tar.gz
gst-plugins-bad-72e3851f87ed6e0f07ba74afb7e260f5bfe8def8.tar.bz2
gst-plugins-bad-72e3851f87ed6e0f07ba74afb7e260f5bfe8def8.zip
ext/directfb/Makefile.am: Add the example application.
Original commit message from CVS: 2005-11-06 Julien MOUTTE <julien@moutte.net> * ext/directfb/Makefile.am: Add the example application. * ext/directfb/dfb-example.c: (get_me_out), (main): Here is an example application that runs videotestsrc for 20 seconds. It's included in the documentation. * ext/directfb/dfbvideosink.c: (gst_dfbvideosink_enum_layers), (gst_dfbvideosink_setup), (gst_dfbvideosink_can_blit_from_format), (gst_dfbvideosink_getcaps), (gst_dfbvideosink_buffer_alloc): More fixes, calculate new size of the buffer when renegotiating. This completely breaks ffmpegcolorspace but i need to discuss that with Wim on monday. Add documentation.
Diffstat (limited to 'ext/directfb/Makefile.am')
-rw-r--r--ext/directfb/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/ext/directfb/Makefile.am b/ext/directfb/Makefile.am
index eb90c28b..7a6a65c6 100644
--- a/ext/directfb/Makefile.am
+++ b/ext/directfb/Makefile.am
@@ -12,3 +12,7 @@ libgstdfbvideosink_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) \
libgstdfbvideosink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = dfbvideosink.h
+
+noinst_PROGRAMS = dfb-example
+dfb_example_CFLAGS = $(GST_CFLAGS) $(DIRECTFB_CFLAGS)
+dfb_example_LDADD = $(GST_LIBS) $(DIRECTFB_LIBS)