summaryrefslogtreecommitdiffstats
path: root/ext/gio/Makefile.am
diff options
context:
space:
mode:
authorRené Stadler <mail@renestadler.de>2007-09-21 17:07:56 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2007-09-21 17:07:56 +0000
commit5739f5f3cec195ca6f9a5a1a1f9de7e4cd1c98f6 (patch)
tree88798381273ffd9162dfca9d271538c7ee2fbe7c /ext/gio/Makefile.am
parent78960f293f797ec40eb5991468853cbb62907ab8 (diff)
downloadgst-plugins-bad-5739f5f3cec195ca6f9a5a1a1f9de7e4cd1c98f6.tar.gz
gst-plugins-bad-5739f5f3cec195ca6f9a5a1a1f9de7e4cd1c98f6.tar.bz2
gst-plugins-bad-5739f5f3cec195ca6f9a5a1a1f9de7e4cd1c98f6.zip
Add a GIO/GVFS plugin with source and sink elements. This will only be enabled when --enable-experimental is given to...
Original commit message from CVS: Patch by: René Stadler <mail at renestadler dot de> * configure.ac: * ext/Makefile.am: * ext/gio/Makefile.am: * ext/gio/gstgio.c: (gst_gio_error), (gst_gio_seek), (gst_gio_get_supported_protocols), (gst_gio_uri_handler_get_type_sink), (gst_gio_uri_handler_get_type_src), (gst_gio_uri_handler_get_protocols), (gst_gio_uri_handler_get_uri), (gst_gio_uri_handler_set_uri), (gst_gio_uri_handler_init), (gst_gio_uri_handler_do_init), (plugin_init): * ext/gio/gstgio.h: * ext/gio/gstgiosink.c: (gst_gio_sink_base_init), (gst_gio_sink_class_init), (gst_gio_sink_init), (gst_gio_sink_finalize), (gst_gio_sink_set_property), (gst_gio_sink_get_property), (gst_gio_sink_start), (gst_gio_sink_stop), (gst_gio_sink_unlock), (gst_gio_sink_unlock_stop), (gst_gio_sink_event), (gst_gio_sink_render), (gst_gio_sink_query): * ext/gio/gstgiosink.h: * ext/gio/gstgiosrc.c: (gst_gio_src_base_init), (gst_gio_src_class_init), (gst_gio_src_init), (gst_gio_src_finalize), (gst_gio_src_set_property), (gst_gio_src_get_property), (gst_gio_src_start), (gst_gio_src_stop), (gst_gio_src_get_size), (gst_gio_src_is_seekable), (gst_gio_src_unlock), (gst_gio_src_unlock_stop), (gst_gio_src_check_get_range), (gst_gio_src_create): * ext/gio/gstgiosrc.h: Add a GIO/GVFS plugin with source and sink elements. This will only be enabled when --enable-experimental is given to configure for now as the GIO API is not stable yet. Fixes #476916.
Diffstat (limited to 'ext/gio/Makefile.am')
-rw-r--r--ext/gio/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/ext/gio/Makefile.am b/ext/gio/Makefile.am
new file mode 100644
index 00000000..15d57449
--- /dev/null
+++ b/ext/gio/Makefile.am
@@ -0,0 +1,13 @@
+# plugindir is set in configure
+
+plugin_LTLIBRARIES = libgstgio.la
+
+# sources used to compile this plug-in
+libgstgio_la_SOURCES = gstgio.c gstgiosink.c gstgiosrc.c
+
+libgstgio_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(GIO_CFLAGS)
+libgstgio_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(GIO_LIBS)
+libgstgio_la_LDFLAGS = $(GST_GIO_LDFLAGS)
+
+# headers we need but don't want installed
+noinst_HEADERS = gstgio.h gstgiosink.h gstgiosrc.h