summaryrefslogtreecommitdiffstats
path: root/ext/ivorbis/Makefile.am
diff options
context:
space:
mode:
authorEdgard Lima <edgard.lima@indt.org.br>2005-11-21 03:21:04 +0000
committerEdgard Lima <edgard.lima@indt.org.br>2005-11-21 03:21:04 +0000
commit7f1b45229fa255f362ae560a785f9d99af14bc14 (patch)
tree0f0f221a8c7bcb17da2dda1d2758b5562af6ac91 /ext/ivorbis/Makefile.am
parentbfa08e84d162e96c51b1e577f50f8c30b211818a (diff)
downloadgst-plugins-bad-7f1b45229fa255f362ae560a785f9d99af14bc14.tar.gz
gst-plugins-bad-7f1b45229fa255f362ae560a785f9d99af14bc14.tar.bz2
gst-plugins-bad-7f1b45229fa255f362ae560a785f9d99af14bc14.zip
Now it works in push-mode. Tested with gnomevfssrc location=http://.. ! tremor ! alsasink.
Original commit message from CVS: Now it works in push-mode. Tested with gnomevfssrc location=http://.. ! tremor ! alsasink. Some issues to be solved yet: 1- set correct timestamps 2- seek is forced to disabled in pull-mode
Diffstat (limited to 'ext/ivorbis/Makefile.am')
-rw-r--r--ext/ivorbis/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/ext/ivorbis/Makefile.am b/ext/ivorbis/Makefile.am
index 1427f972..13ef42ed 100644
--- a/ext/ivorbis/Makefile.am
+++ b/ext/ivorbis/Makefile.am
@@ -2,7 +2,11 @@
plugin_LTLIBRARIES = libgstivorbis.la
libgstivorbis_la_SOURCES = vorbis.c vorbisfile.c
-libgstivorbis_la_CFLAGS = $(GST_CFLAGS) $(IVORBIS_CFLAGS)
-libgstivorbis_la_LIBADD = $(IVORBIS_LIBS) $(IVORBISFILE_LIBS)
+libgstivorbis_la_CFLAGS = $(GST_CFLAGS) $(IVORBIS_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstivorbis_la_LIBADD = $(IVORBIS_LIBS) \
+ $(IVORBISFILE_LIBS) \
+ $(GST_BASE_LIBS) \
+ $(GST_PLUGINS_BASE_LIBS) \
+ -lgstaudio-@GST_MAJORMINOR@
libgstivorbis_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)