summaryrefslogtreecommitdiffstats
path: root/ext/musepack/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2004-11-07 18:30:06 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2004-11-07 18:30:06 +0000
commit868291efc42d7b66bfdafe0eded0b38ccad0b3b1 (patch)
treee92a7f534e4ae857d36efd030646bee667f613ba /ext/musepack/Makefile.am
parentc69f0127dfa452cedddc8e87e28b59e41eea4d9a (diff)
downloadgst-plugins-bad-868291efc42d7b66bfdafe0eded0b38ccad0b3b1.tar.gz
gst-plugins-bad-868291efc42d7b66bfdafe0eded0b38ccad0b3b1.tar.bz2
gst-plugins-bad-868291efc42d7b66bfdafe0eded0b38ccad0b3b1.zip
Add musepack decoder.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/musepack/Makefile.am: * ext/musepack/gstmusepackdec.cpp: * ext/musepack/gstmusepackdec.h: * ext/musepack/gstmusepackreader.cpp: * ext/musepack/gstmusepackreader.h: Add musepack decoder. * ext/faad/gstfaad.c: (gst_faad_base_init): Make pad templates static. * gst/typefind/gsttypefindfunctions.c: (mp3_type_find), (plugin_init): Add musepack typefinder, make mp3 typefinding work halfway stream, which doesn't actually work yet because id3demux doesn't implement _get_length().
Diffstat (limited to 'ext/musepack/Makefile.am')
-rw-r--r--ext/musepack/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/ext/musepack/Makefile.am b/ext/musepack/Makefile.am
new file mode 100644
index 00000000..3c3b1bfa
--- /dev/null
+++ b/ext/musepack/Makefile.am
@@ -0,0 +1,12 @@
+plugin_LTLIBRARIES = libgstmusepack.la
+
+libgstmusepack_la_SOURCES = \
+ gstmusepackdec.cpp \
+ gstmusepackreader.cpp
+libgstmusepack_la_CXXFLAGS = $(MUSEPACK_CFLAGS) $(GST_CFLAGS)
+libgstmusepack_la_LIBADD = $(MUSEPACK_LIBS)
+libgstmusepack_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = \
+ gstmusepackdec.h \
+ gstmusepackreader.h