summaryrefslogtreecommitdiffstats
path: root/ext/smoothwave/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2002-01-04 21:53:21 +0000
committerAndy Wingo <wingo@pobox.com>2002-01-04 21:53:21 +0000
commitd16d24c9b227ea2ccb7d90070b2b4587efcaabab (patch)
tree5f06a9f794383ee7033d391954c8830816ff6c54 /ext/smoothwave/Makefile.am
parent684fe6b617b1dbd5ca3c5ba5392e4542d124c86a (diff)
downloadgst-plugins-bad-d16d24c9b227ea2ccb7d90070b2b4587efcaabab.tar.gz
gst-plugins-bad-d16d24c9b227ea2ccb7d90070b2b4587efcaabab.tar.bz2
gst-plugins-bad-d16d24c9b227ea2ccb7d90070b2b4587efcaabab.zip
wave.c -> demo-osssrc.c this is probably broken, but then so is smoothwave
Original commit message from CVS: wave.c -> demo-osssrc.c this is probably broken, but then so is smoothwave
Diffstat (limited to 'ext/smoothwave/Makefile.am')
-rw-r--r--ext/smoothwave/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/smoothwave/Makefile.am b/ext/smoothwave/Makefile.am
index f000c7a4..e46a9572 100644
--- a/ext/smoothwave/Makefile.am
+++ b/ext/smoothwave/Makefile.am
@@ -8,4 +8,12 @@ libgstsmoothwave_la_LIBADD = $(GTK_LIBS)
noinst_HEADERS = gstsmoothwave.h
+if HAVE_GTK
+noinst_PROGRAMS = demo-osssrc
+endif
+
+demo_osssrc_SOURCES = demo-osssrc.c
+demo_osssrc_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS)
+demo_osssrc_LDFLAGS = $(GST_LIBS) $(GTK_LIBS)
+
EXTRA_DIST = README