summaryrefslogtreecommitdiffstats
path: root/ext/soundtouch/Makefile.am
diff options
context:
space:
mode:
authorWouter Paesen <wouter@kangaroot.net>2006-06-14 18:07:51 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-06-14 18:07:51 +0000
commit34f03fe525ac9c9e646ac77b9b0b655bd46d433b (patch)
tree9fc3d837bc70e7ffc468e796146c5620499e53e9 /ext/soundtouch/Makefile.am
parentbed0b905a19551aa9cfec0dcfd1f744c1576c5a1 (diff)
downloadgst-plugins-bad-34f03fe525ac9c9e646ac77b9b0b655bd46d433b.tar.gz
gst-plugins-bad-34f03fe525ac9c9e646ac77b9b0b655bd46d433b.tar.bz2
gst-plugins-bad-34f03fe525ac9c9e646ac77b9b0b655bd46d433b.zip
ext/soundtouch/: Make pitch element controllable via GstController interface (#344821).
Original commit message from CVS: Patch by: Wouter Paesen <wouter at kangaroot net> * ext/soundtouch/Makefile.am: * ext/soundtouch/gstpitch.cc: Make pitch element controllable via GstController interface (#344821). * configure.ac: Up core requirements to 0.10.8.1/CVS because earlier GstControllers can't handle float properties correctly. Check for GstController CFLAGS and LIBS. * tests/icles/Makefile.am: * tests/icles/pitch-test.c: (main): Add small test program for the above (welcome to the 80s!).
Diffstat (limited to 'ext/soundtouch/Makefile.am')
-rw-r--r--ext/soundtouch/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/ext/soundtouch/Makefile.am b/ext/soundtouch/Makefile.am
index d286bfce..e7523bfb 100644
--- a/ext/soundtouch/Makefile.am
+++ b/ext/soundtouch/Makefile.am
@@ -2,8 +2,8 @@ plugin_LTLIBRARIES = libgstpitch.la
libgstpitch_la_SOURCES = gstpitch.cc
-libgstpitch_la_CXXFLAGS = @GST_CFLAGS@ @GST_BASE_CFLAGS@ @SOUNDTOUCH_CFLAGS@
-libgstpitch_la_LIBADD = @GST_LIBS@ @GST_BASE_LIBS@ @SOUNDTOUCH_LIBS@
-libgstpitch_la_LDFLAGS = @GST_PLUGIN_LDFLAGS@
+libgstpitch_la_CXXFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) $(SOUNDTOUCH_CFLAGS) $(GST_CONTROLLER_CFLAGS)
+libgstpitch_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(SOUNDTOUCH_LIBS) $(GST_CONTROLLER_LIBS)
+libgstpitch_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstpitch.hh