summaryrefslogtreecommitdiffstats
path: root/ext/tarkin/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2002-02-03 16:30:31 +0000
committerWim Taymans <wim.taymans@gmail.com>2002-02-03 16:30:31 +0000
commit57ce0321c8971f964008920003a3e8b19649df85 (patch)
treebabe3c6e4473b4f06142b587db73f2212ec44c42 /ext/tarkin/Makefile.am
parentb1fea046869baeed3c6835f20db9f5de9fd912d2 (diff)
downloadgst-plugins-bad-57ce0321c8971f964008920003a3e8b19649df85.tar.gz
gst-plugins-bad-57ce0321c8971f964008920003a3e8b19649df85.tar.bz2
gst-plugins-bad-57ce0321c8971f964008920003a3e8b19649df85.zip
Added a tarkin encoder/decoder plugin.
Original commit message from CVS: Added a tarkin encoder/decoder plugin. I moved the tarking CVS code in here temporarily until they have a library (hence this plugin is in ext) test with: ./gst-launch filesrc location=/opt/data/shihad.mpg ! mpegdemux video_00! { queue ! mpeg2dec ! colorspace ! tarkinenc bitrate=3000 ! disksink location=out.ogg } ./gst-launch filesrc location=out.ogg ! tarkindec ! colorspace ! xvideosink
Diffstat (limited to 'ext/tarkin/Makefile.am')
-rw-r--r--ext/tarkin/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/ext/tarkin/Makefile.am b/ext/tarkin/Makefile.am
new file mode 100644
index 00000000..86acce1f
--- /dev/null
+++ b/ext/tarkin/Makefile.am
@@ -0,0 +1,15 @@
+plugindir = $(libdir)/gst
+
+plugin_LTLIBRARIES = libgsttarkin.la
+
+libgsttarkin_la_SOURCES = tarkin.c \
+ mem.c wavelet.c wavelet_xform.c \
+ wavelet_coeff.c yuv.c info.c \
+ gsttarkin.c gsttarkinenc.c gsttarkindec.c
+
+libgsttarkin_la_CFLAGS = $(GST_CFLAGS) $(VORBIS_CFLAGS) -DTYPE_BITS=10 -DTYPE=int16_t -DRLECODER
+## AM_PATH_VORBIS also sets VORBISENC_LIBS
+libgsttarkin_la_LIBADD = $(GST_LIBS) $(VORBIS_LIBS) $(VORBISENC_LIBS)
+libgsttarkin_la_LDFLAGS = @GST_PLUGIN_LDFLAGS@
+
+noinst_HEADERS = gsttarkinenc.h