summaryrefslogtreecommitdiffstats
path: root/ext/xine/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2004-02-22 20:52:15 +0000
committerBenjamin Otte <otte@gnome.org>2004-02-22 20:52:15 +0000
commitcf56a9746841cff70b6f22a698710a49428d6198 (patch)
tree8669a733cc0fbacbaefd15576d45460c479909a6 /ext/xine/Makefile.am
parent526d484fb3535e76092da27b4c29c1c4a2cb2790 (diff)
downloadgst-plugins-bad-cf56a9746841cff70b6f22a698710a49428d6198.tar.gz
gst-plugins-bad-cf56a9746841cff70b6f22a698710a49428d6198.tar.bz2
gst-plugins-bad-cf56a9746841cff70b6f22a698710a49428d6198.zip
ext/xine/: add input plugin wrapper. Playback from files, http, mms and cdda works.
Original commit message from CVS: 2004-02-22 Benjamin Otte <otte@gnome.org> * ext/xine/Makefile.am: * ext/xine/gstxine.h: * ext/xine/xine.c: (plugin_init): * ext/xine/xineinput.c: add input plugin wrapper. Playback from files, http, mms and cdda works. * ext/xine/xineaudiodec.c: (gst_xine_audio_dec_chain): remove leftover G_GNUC_UNUSED * gst/asfdemux/gstasfdemux.c: (gst_asf_demux_process_stream), (gst_asf_demux_identify_guid): improve debugging output
Diffstat (limited to 'ext/xine/Makefile.am')
-rw-r--r--ext/xine/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/ext/xine/Makefile.am b/ext/xine/Makefile.am
index b67889c7..68707cfb 100644
--- a/ext/xine/Makefile.am
+++ b/ext/xine/Makefile.am
@@ -2,7 +2,7 @@ plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
plugin_LTLIBRARIES = libgstxine.la
-libgstxine_la_SOURCES = xine.c xinecaps.c xineaudiodec.c
+libgstxine_la_SOURCES = xine.c xinecaps.c xineaudiodec.c xineinput.c
libgstxine_la_CFLAGS = $(GST_CFLAGS) $(XINE_CFLAGS)
libgstxine_la_LIBADD = $(XINE_LIBS)
libgstxine_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)