summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/mixer/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2004-05-27 03:36:17 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2004-05-27 03:36:17 +0000
commit2652468b976e56a219c35259e03efc8f1e189e13 (patch)
treed24b947e4dcfd3efee18897e2bf72e2d14518ce3 /gst-libs/gst/mixer/Makefile.am
parentb897ebfaec8e13384bc51e164197bc7acfda0c7d (diff)
downloadgst-plugins-bad-2652468b976e56a219c35259e03efc8f1e189e13.tar.gz
gst-plugins-bad-2652468b976e56a219c35259e03efc8f1e189e13.tar.bz2
gst-plugins-bad-2652468b976e56a219c35259e03efc8f1e189e13.zip
ext/alsa/: Add enumerations (as GstMixerOptions). Make correct distinction between input/output tracks. Add capture/p...
Original commit message from CVS: * ext/alsa/Makefile.am: * ext/alsa/gstalsamixer.c: (gst_alsa_mixer_interface_init), (gst_alsa_mixer_build_list), (gst_alsa_mixer_get_volume), (gst_alsa_mixer_set_volume), (gst_alsa_mixer_set_mute), (gst_alsa_mixer_set_record), (gst_alsa_mixer_set_option), (gst_alsa_mixer_get_option): * ext/alsa/gstalsamixer.h: * ext/alsa/gstalsamixeroptions.c: (gst_alsa_mixer_options_get_type), (gst_alsa_mixer_options_class_init), (gst_alsa_mixer_options_init), (gst_alsa_mixer_options_new): * ext/alsa/gstalsamixeroptions.h: * ext/alsa/gstalsamixertrack.c: (gst_alsa_mixer_track_new): * ext/alsa/gstalsamixertrack.h: Add enumerations (as GstMixerOptions). Make correct distinction between input/output tracks. Add capture/playback private flag. Use flag to decide on whether to set capture or playback volumes or switches. Use playback and record switches. * gst-libs/gst/mixer/Makefile.am: * gst-libs/gst/mixer/mixer-marshal.list: * gst-libs/gst/mixer/mixer.c: (gst_mixer_class_init), (gst_mixer_set_option), (gst_mixer_get_option), (gst_mixer_mute_toggled), (gst_mixer_record_toggled), (gst_mixer_volume_changed), (gst_mixer_option_changed): * gst-libs/gst/mixer/mixer.h: * gst-libs/gst/mixer/mixeroptions.c: (gst_mixer_options_get_type), (gst_mixer_options_class_init), (gst_mixer_options_init), (gst_mixer_options_dispose): * gst-libs/gst/mixer/mixeroptions.h: Add GstMixerOptions. * sys/oss/gstosselement.c: (gst_osselement_class_probe_devices): Rename Audio Mixer to OSS Mixer (similar to Alsa Mixer). Fix broken device detection on computers with multiple OSS sound cards.
Diffstat (limited to 'gst-libs/gst/mixer/Makefile.am')
-rw-r--r--gst-libs/gst/mixer/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/gst-libs/gst/mixer/Makefile.am b/gst-libs/gst/mixer/Makefile.am
index a77936c2..e556ab0e 100644
--- a/gst-libs/gst/mixer/Makefile.am
+++ b/gst-libs/gst/mixer/Makefile.am
@@ -9,6 +9,7 @@ libgstmixerincludedir = \
mixer_headers = \
mixer.h \
+ mixeroptions.h \
mixertrack.h
built_sources = \
@@ -27,7 +28,9 @@ noinst_LTLIBRARIES = libgstmixer.la
libgstmixer_la_SOURCES = \
mixer.c \
+ mixeroptions.c \
mixertrack.c
+
nodist_libgstmixer_la_SOURCES = \
mixer-marshal.h \
$(built_sources)