summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/mixer/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-12-07 12:11:30 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-12-07 12:11:30 +0000
commit9bda5831b8818d0fe4286fdb1217085913277c0d (patch)
tree404583dd41a644b2e2dd72aa587357b252c135d8 /gst-libs/gst/mixer/Makefile.am
parentef074394e68785508b4def25078ffaba572cb0c8 (diff)
downloadgst-plugins-bad-9bda5831b8818d0fe4286fdb1217085913277c0d.tar.gz
gst-plugins-bad-9bda5831b8818d0fe4286fdb1217085913277c0d.tar.bz2
gst-plugins-bad-9bda5831b8818d0fe4286fdb1217085913277c0d.zip
Move over from GstInterface to GstImplementsInterface. Also adds some signals to several interfaces
Original commit message from CVS: Move over from GstInterface to GstImplementsInterface. Also adds some signals to several interfaces
Diffstat (limited to 'gst-libs/gst/mixer/Makefile.am')
-rw-r--r--gst-libs/gst/mixer/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/gst-libs/gst/mixer/Makefile.am b/gst-libs/gst/mixer/Makefile.am
index 193b5a10..f62ab4c8 100644
--- a/gst-libs/gst/mixer/Makefile.am
+++ b/gst-libs/gst/mixer/Makefile.am
@@ -9,5 +9,23 @@ noinst_LTLIBRARIES = libgstmixer.la
libgstmixer_la_SOURCES = \
mixer.c \
- mixertrack.c
+ mixertrack.c \
+ mixermarshal.c
libgstmixer_la_CFLAGS = $(GST_CFLAGS)
+
+BUILT_SOURCES = \
+ mixermarshal.c \
+ mixermarshal.h
+built_headers = \
+ mixermarshal.h
+
+EXTRA_DIST = mixermarshal.list
+
+mixermarshal.h: mixermarshal.list
+ glib-genmarshal --header --prefix=gst_mixer_marshal $^ > mixermarshal.h.tmp
+ mv mixermarshal.h.tmp mixermarshal.h
+
+mixermarshal.c: mixermarshal.list
+ echo "#include \"mixermarshal.h\"" >> mixermarshal.c.tmp
+ glib-genmarshal --body --prefix=gst_mixer_marshal $^ >> mixermarshal.c.tmp
+ mv mixermarshal.c.tmp mixermarshal.c