summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/tuner/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2003-12-18 09:49:50 +0000
committerDavid Schleef <ds@schleef.org>2003-12-18 09:49:50 +0000
commitef3ed344af7d0eb330f68c85d31acfa9471d1573 (patch)
tree012d45187cfa98f972073142ce341190252e17f7 /gst-libs/gst/tuner/Makefile.am
parent70a4a0e00218745b2bf7ad0b145fe9a967981cb4 (diff)
downloadgst-plugins-bad-ef3ed344af7d0eb330f68c85d31acfa9471d1573.tar.gz
gst-plugins-bad-ef3ed344af7d0eb330f68c85d31acfa9471d1573.tar.bz2
gst-plugins-bad-ef3ed344af7d0eb330f68c85d31acfa9471d1573.zip
Merge HEAD from CAPS-ROOT to CAPS-MERGE-3
Original commit message from CVS: Merge HEAD from CAPS-ROOT to CAPS-MERGE-3
Diffstat (limited to 'gst-libs/gst/tuner/Makefile.am')
-rw-r--r--gst-libs/gst/tuner/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/gst-libs/gst/tuner/Makefile.am b/gst-libs/gst/tuner/Makefile.am
index 6d14130d..f25ab297 100644
--- a/gst-libs/gst/tuner/Makefile.am
+++ b/gst-libs/gst/tuner/Makefile.am
@@ -11,6 +11,25 @@ noinst_LTLIBRARIES = libgsttuner.la
libgsttuner_la_SOURCES = \
tuner.c \
tunernorm.c \
- tunerchannel.c
+ tunerchannel.c \
+ tunermarshal.c
libgsttuner_la_CFLAGS = $(GST_CFLAGS)
+BUILT_SOURCES = \
+ tunermarshal.c \
+ tunermarshal.h
+built_headers = \
+ tunermarshal.h
+
+EXTRA_DIST = tunermarshal.list
+
+CLEANFILES = $(BUILT_SOURCES)
+
+tunermarshal.h: tunermarshal.list
+ glib-genmarshal --header --prefix=gst_tuner_marshal $^ > tunermarshal.h.tmp
+ mv tunermarshal.h.tmp tunermarshal.h
+
+tunermarshal.c: tunermarshal.list
+ echo "#include \"tunermarshal.h\"" >> tunermarshal.c.tmp
+ glib-genmarshal --body --prefix=gst_tuner_marshal $^ >> tunermarshal.c.tmp
+ mv tunermarshal.c.tmp tunermarshal.c