summaryrefslogtreecommitdiffstats
path: root/gst/equalizer/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2007-02-24 22:52:48 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-02-24 22:52:48 +0000
commitbc8d60a4e34445d4fe95e50654a737ad91d52772 (patch)
tree0f99d40bc59b537ffe102341b9e0987015e54f32 /gst/equalizer/Makefile.am
parentda5144bc04185eff0cf95b8fbc6da347007b8a81 (diff)
downloadgst-plugins-bad-bc8d60a4e34445d4fe95e50654a737ad91d52772.tar.gz
gst-plugins-bad-bc8d60a4e34445d4fe95e50654a737ad91d52772.tar.bz2
gst-plugins-bad-bc8d60a4e34445d4fe95e50654a737ad91d52772.zip
Fix build with LDFLAGS='-Wl,-z,defs'.
Original commit message from CVS: * configure.ac: * ext/gsm/Makefile.am: * ext/ladspa/Makefile.am: * ext/wavpack/Makefile.am: * gst/equalizer/Makefile.am: * gst/filter/Makefile.am: * gst/mve/Makefile.am: * gst/nsf/Makefile.am: * gst/replaygain/Makefile.am: * gst/speed/Makefile.am: Fix build with LDFLAGS='-Wl,-z,defs'.
Diffstat (limited to 'gst/equalizer/Makefile.am')
-rw-r--r--gst/equalizer/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gst/equalizer/Makefile.am b/gst/equalizer/Makefile.am
index 1ef12c94..f4f2198c 100644
--- a/gst/equalizer/Makefile.am
+++ b/gst/equalizer/Makefile.am
@@ -1,8 +1,8 @@
plugin_LTLIBRARIES = libgstequalizer.la
libgstequalizer_la_SOURCES = gstiirequalizer.c gstiirequalizer.h
-libgstequalizer_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
-libgstequalizer_la_LIBADD = $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR)
+libgstequalizer_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS)
+libgstequalizer_la_LIBADD = $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) $(GST_BASE_LIBS) $(LIBM)
libgstequalizer_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstiirequalizer.h