summaryrefslogtreecommitdiffstats
path: root/gst/librfb/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2005-02-11 22:01:19 +0000
committerDavid Schleef <ds@schleef.org>2005-02-11 22:01:19 +0000
commita970a323047d9241a4ee96f4126c9739fc9780cf (patch)
tree0cc2c90fba41e659ddfa701c08f9bc0b95545427 /gst/librfb/Makefile.am
parent909da9fb0489c3744547e6386531461c072da5fc (diff)
downloadgst-plugins-bad-a970a323047d9241a4ee96f4126c9739fc9780cf.tar.gz
gst-plugins-bad-a970a323047d9241a4ee96f4126c9739fc9780cf.tar.bz2
gst-plugins-bad-a970a323047d9241a4ee96f4126c9739fc9780cf.zip
configure.ac: Pull in librfb from my CVS tree, because it is too small and annoying to be separate. Move rfbsrc plug...
Original commit message from CVS: * configure.ac: Pull in librfb from my CVS tree, because it is too small and annoying to be separate. Move rfbsrc plugin to gst/. * ext/Makefile.am: * ext/librfb/Makefile.am: * ext/librfb/gstrfbsrc.c: * gst/librfb/Makefile.am: * gst/librfb/gstrfbsrc.c: * gst/librfb/rfb.c: * gst/librfb/rfb.h: * gst/librfb/rfbbuffer.c: * gst/librfb/rfbbuffer.h: * gst/librfb/rfbbytestream.c: * gst/librfb/rfbbytestream.h: * gst/librfb/rfbcontext.h: * gst/librfb/rfbdecoder.c: * gst/librfb/rfbdecoder.h: * gst/librfb/rfbutil.h:
Diffstat (limited to 'gst/librfb/Makefile.am')
-rw-r--r--gst/librfb/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/gst/librfb/Makefile.am b/gst/librfb/Makefile.am
new file mode 100644
index 00000000..67505440
--- /dev/null
+++ b/gst/librfb/Makefile.am
@@ -0,0 +1,30 @@
+
+# please keep librfb easily extractable
+
+noinst_LTLIBRARIES = librfb.la
+plugin_LTLIBRARIES = libgstrfbsrc.la
+
+libgstrfbsrc_la_SOURCES = gstrfbsrc.c
+libgstrfbsrc_la_CFLAGS = $(GST_CFLAGS) -I/usr/local/include/librfb-0.1
+libgstrfbsrc_la_LIBADD = librfb.la
+libgstrfbsrc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+
+noinst_HEADERS = \
+ rfb.h \
+ rfbdecoder.h \
+ rfbbuffer.h \
+ rfbbytestream.h
+
+librfb_la_SOURCES = \
+ rfb.h \
+ rfbdecoder.c \
+ rfbdecoder.h \
+ rfbbuffer.c \
+ rfbbuffer.h \
+ rfbbytestream.c \
+ rfbbytestream.h
+
+librfb_la_CFLAGS = $(RFB_CFLAGS)
+librfb_la_LIBADD = $(GLIB_LIBS)
+