summaryrefslogtreecommitdiffstats
path: root/gst/mpegaudioparse/Makefile.am
diff options
context:
space:
mode:
authorBrian Cameron <brian.cameron@sun.com>2003-05-21 15:16:51 +0000
committerBrian Cameron <brian.cameron@sun.com>2003-05-21 15:16:51 +0000
commita62ca0048edd89cff24bc4550b456cf875bc5439 (patch)
treeb3f5e4c74904d2ac72564788161db8a54882cb6c /gst/mpegaudioparse/Makefile.am
parent5198587eb428d80476e85fcd72065294db708fb2 (diff)
downloadgst-plugins-bad-a62ca0048edd89cff24bc4550b456cf875bc5439.tar.gz
gst-plugins-bad-a62ca0048edd89cff24bc4550b456cf875bc5439.tar.bz2
gst-plugins-bad-a62ca0048edd89cff24bc4550b456cf875bc5439.zip
Updated autogen.sh/configure.ac and various Makefiles to make the configure script set up all gcc specific compiler a...
Original commit message from CVS: Updated autogen.sh/configure.ac and various Makefiles to make the configure script set up all gcc specific compiler arguments, rather than hardcoding them in the Makefile.am files
Diffstat (limited to 'gst/mpegaudioparse/Makefile.am')
-rw-r--r--gst/mpegaudioparse/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gst/mpegaudioparse/Makefile.am b/gst/mpegaudioparse/Makefile.am
index 06b3f91d..8b81fcc4 100644
--- a/gst/mpegaudioparse/Makefile.am
+++ b/gst/mpegaudioparse/Makefile.am
@@ -5,12 +5,12 @@ plugin_LTLIBRARIES = libgstmpegaudioparse.la libgstmp3types.la
libgstmpegaudioparse_la_SOURCES = gstmpegaudioparse.c
# FIXME is this useful?
-libgstmpegaudioparse_la_CFLAGS = -O3 $(FOMIT_FRAME_POINTER) -ffast-math -finline-functions $(GST_CFLAGS)
+libgstmpegaudioparse_la_CFLAGS = -O3 $(FOMIT_FRAME_POINTER) $(GST_OPT_CFLAGS) $(GST_CFLAGS)
libgstmpegaudioparse_la_LIBADD =
libgstmpegaudioparse_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstmp3types_la_SOURCES = gstmp3types.c
-libgstmp3types_la_CFLAGS = -O3 $(FOMIT_FRAME_POINTER) -ffast-math -finline-functions $(GST_CFLAGS)
+libgstmp3types_la_CFLAGS = -O3 $(FOMIT_FRAME_POINTER) $(GST_OPT_CFLAGS) $(GST_CFLAGS)
libgstmp3types_la_LIBADD =
libgstmp3types_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)