summaryrefslogtreecommitdiffstats
path: root/gst/mpegtsparse/Makefile.am
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerabbas@merali.org>2008-01-22 18:04:04 +0000
committerZaheer Abbas Merali <zaheerabbas@merali.org>2008-01-22 18:04:04 +0000
commit32b0966ec7b0dcbd8004f83ac75c3bd5eea011f8 (patch)
treee72f2cafe8c3257f5c313a0ab66871b6dbf8ef3b /gst/mpegtsparse/Makefile.am
parent9b1dd1311d74a5c273517b8ae74070a407466c2c (diff)
downloadgst-plugins-bad-32b0966ec7b0dcbd8004f83ac75c3bd5eea011f8.tar.gz
gst-plugins-bad-32b0966ec7b0dcbd8004f83ac75c3bd5eea011f8.tar.bz2
gst-plugins-bad-32b0966ec7b0dcbd8004f83ac75c3bd5eea011f8.zip
gst/mpegtsparse/: Added descriptor searching infrastructure from Fluendo TS demuxer.
Original commit message from CVS: * gst/mpegtsparse/Makefile.am: * gst/mpegtsparse/gstmpegdesc.c: * gst/mpegtsparse/gstmpegdesc.h: * gst/mpegtsparse/mpegtspacketizer.c: * gst/mpegtsparse/mpegtsparse.c: Added descriptor searching infrastructure from Fluendo TS demuxer. Add channel name and provider to the sdt structure sent in the bus message.
Diffstat (limited to 'gst/mpegtsparse/Makefile.am')
-rw-r--r--gst/mpegtsparse/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/gst/mpegtsparse/Makefile.am b/gst/mpegtsparse/Makefile.am
index 66f89f30..d85c2385 100644
--- a/gst/mpegtsparse/Makefile.am
+++ b/gst/mpegtsparse/Makefile.am
@@ -2,7 +2,8 @@ plugin_LTLIBRARIES = libgstmpegtsparse.la
libgstmpegtsparse_la_SOURCES = \
mpegtsparse.c \
- mpegtspacketizer.c
+ mpegtspacketizer.c \
+ gstmpegdesc.c
libgstmpegtsparse_la_CFLAGS = $(GST_CFLAGS)
libgstmpegtsparse_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS)
@@ -10,4 +11,5 @@ libgstmpegtsparse_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = \
mpegtsparse.h \
- mpegtspacketizer.h
+ mpegtspacketizer.h \
+ gstmpegdesc.h