summaryrefslogtreecommitdiffstats
path: root/gst/mpegtsparse/Makefile.am
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerabbas@merali.org>2007-08-20 14:23:45 +0000
committerZaheer Abbas Merali <zaheerabbas@merali.org>2007-08-20 14:23:45 +0000
commite6c86a500d6e09439a54a82e2cfa2af9f13c5228 (patch)
tree7266ddeddc8651375461d8ec5257e853fef7b36b /gst/mpegtsparse/Makefile.am
parentcd2e9804d6a54744c445821d642f0254454e19bf (diff)
downloadgst-plugins-bad-e6c86a500d6e09439a54a82e2cfa2af9f13c5228.tar.gz
gst-plugins-bad-e6c86a500d6e09439a54a82e2cfa2af9f13c5228.tar.bz2
gst-plugins-bad-e6c86a500d6e09439a54a82e2cfa2af9f13c5228.zip
Add mpeg transport stream parser written by:
Original commit message from CVS: * configure.ac: * gst/mpegtsparse/Makefile.am: * gst/mpegtsparse/flutspatinfo.c: * gst/mpegtsparse/flutspatinfo.h: * gst/mpegtsparse/flutspmtinfo.c: * gst/mpegtsparse/flutspmtinfo.h: * gst/mpegtsparse/flutspmtstreaminfo.c: * gst/mpegtsparse/flutspmtstreaminfo.h: * gst/mpegtsparse/mpegtspacketizer.c: * gst/mpegtsparse/mpegtspacketizer.h: * gst/mpegtsparse/mpegtsparse.c: * gst/mpegtsparse/mpegtsparse.h: * gst/mpegtsparse/mpegtsparsemarshal.list: Add mpeg transport stream parser written by: Alessandro Decina. Includes a couple of files from the Fluendo transport stream demuxer that Fluendo have kindly allowed to be licenced under LGPL also.
Diffstat (limited to 'gst/mpegtsparse/Makefile.am')
-rw-r--r--gst/mpegtsparse/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/gst/mpegtsparse/Makefile.am b/gst/mpegtsparse/Makefile.am
new file mode 100644
index 00000000..3324a32b
--- /dev/null
+++ b/gst/mpegtsparse/Makefile.am
@@ -0,0 +1,38 @@
+plugin_LTLIBRARIES = libgstmpegtsparse.la
+
+libgstmpegtsparse_la_SOURCES = \
+ mpegtsparse.c \
+ mpegtspacketizer.c\
+ mpegtsparsemarshal.c \
+ flutspatinfo.c \
+ flutspmtinfo.c \
+ flutspmtstreaminfo.c
+
+BUILT_SOURCES = \
+ mpegtsparsemarshal.h \
+ mpegtsparsemarshal.c
+CLEANFILES = $(BUILT_SOURCES)
+
+EXTRA_libgstmpegtsparse_la_SOURCES = \
+ mpegtsparsemarshal.list
+
+mpegtsparsemarshal.h: mpegtsparsemarshal.list
+ glib-genmarshal --header --prefix=mpegts_parse_marshal $(srcdir)/mpegtsparsemarshal.list > mpegtsparsemarshal.h.tmp
+ mv mpegtsparsemarshal.h.tmp mpegtsparsemarshal.h
+
+mpegtsparsemarshal.c: mpegtsparsemarshal.list mpegtsparsemarshal.h
+ echo "#include \"mpegtsparsemarshal.h\"" >> mpegtsparsemarshal.c.tmp
+ glib-genmarshal --body --prefix=mpegts_parse_marshal $(srcdir)/mpegtsparsemarshal.list >> mpegtsparsemarshal.c.tmp
+ mv mpegtsparsemarshal.c.tmp mpegtsparsemarshal.c
+
+libgstmpegtsparse_la_CFLAGS = $(GST_CFLAGS)
+libgstmpegtsparse_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS)
+libgstmpegtsparse_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = \
+ mpegtsparse.h \
+ mpegtsparsemarshal.h \
+ mpegtspacketizer.h \
+ flutspatinfo.h \
+ flutspmtinfo.h \
+ flutspmtstreaminfo.h