summaryrefslogtreecommitdiffstats
path: root/gst/qtdemux/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2007-01-05 18:32:03 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-01-05 18:32:03 +0000
commit1bf15564bf9ff6d5e1b70816e80aeae2d2c1e1a8 (patch)
treeb7e28e5cf0e4d03d3a57b971ee2cbdbbb1395a94 /gst/qtdemux/Makefile.am
parent5b4a32581104b18d084ff97c65fa91afc653c487 (diff)
downloadgst-plugins-bad-1bf15564bf9ff6d5e1b70816e80aeae2d2c1e1a8.tar.gz
gst-plugins-bad-1bf15564bf9ff6d5e1b70816e80aeae2d2c1e1a8.tar.bz2
gst-plugins-bad-1bf15564bf9ff6d5e1b70816e80aeae2d2c1e1a8.zip
Check for zlib and if available pass it explicitly to the linker when linking qtdemux. If not available (or --disable...
Original commit message from CVS: * configure.ac: * gst/qtdemux/Makefile.am: * gst/qtdemux/qtdemux.c: (qtdemux_parse_moov): Check for zlib and if available pass it explicitly to the linker when linking qtdemux. If not available (or --disable-external has been specified!), disable the bits in qtdemux that use it. Fixes build on MingW (#392856).
Diffstat (limited to 'gst/qtdemux/Makefile.am')
-rw-r--r--gst/qtdemux/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gst/qtdemux/Makefile.am b/gst/qtdemux/Makefile.am
index f65f337e..1f480365 100644
--- a/gst/qtdemux/Makefile.am
+++ b/gst/qtdemux/Makefile.am
@@ -2,7 +2,7 @@
plugin_LTLIBRARIES = libgstqtdemux.la
libgstqtdemux_la_CFLAGS = ${GST_CFLAGS}
-libgstqtdemux_la_LIBADD = $(GST_BASE_LIBS)
+libgstqtdemux_la_LIBADD = $(GST_BASE_LIBS) $(ZLIB_LIBS)
libgstqtdemux_la_LDFLAGS = ${GST_PLUGIN_LDFLAGS}
libgstqtdemux_la_SOURCES = qtdemux.c