summaryrefslogtreecommitdiffstats
path: root/gst/qtdemux/Makefile.am
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2006-02-13 22:04:42 +0000
committerEdward Hervey <bilboed@bilboed.com>2006-02-13 22:04:42 +0000
commit49f830d457fbc69dcd9e3e23b44e3d1f5f53499a (patch)
tree2c7b9c10638333d4f350b94a4d17f995ec795a93 /gst/qtdemux/Makefile.am
parentef7b89f382dc536bae955a250d0dc85762fb4a74 (diff)
downloadgst-plugins-bad-49f830d457fbc69dcd9e3e23b44e3d1f5f53499a.tar.gz
gst-plugins-bad-49f830d457fbc69dcd9e3e23b44e3d1f5f53499a.tar.bz2
gst-plugins-bad-49f830d457fbc69dcd9e3e23b44e3d1f5f53499a.zip
gst/qtdemux/: QtDemux can now work push-based.
Original commit message from CVS: * gst/qtdemux/Makefile.am: * gst/qtdemux/qtdemux.c: (gst_qtdemux_init), (gst_qtdemux_handle_sink_event), (gst_qtdemux_change_state), (extract_initial_length_and_fourcc), (gst_qtdemux_loop_state_header), (gst_qtdemux_loop_state_movie), (gst_qtdemux_loop_header), (next_entry_size), (gst_qtdemux_chain), (qtdemux_sink_activate), (qtdemux_sink_activate_pull), (qtdemux_sink_activate_push), (qtdemux_parse_trak): * gst/qtdemux/qtdemux.h: QtDemux can now work push-based. It still needs some love for seeking.
Diffstat (limited to 'gst/qtdemux/Makefile.am')
-rw-r--r--gst/qtdemux/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gst/qtdemux/Makefile.am b/gst/qtdemux/Makefile.am
index 9c6a9659..f65f337e 100644
--- a/gst/qtdemux/Makefile.am
+++ b/gst/qtdemux/Makefile.am
@@ -2,7 +2,7 @@
plugin_LTLIBRARIES = libgstqtdemux.la
libgstqtdemux_la_CFLAGS = ${GST_CFLAGS}
-libgstqtdemux_la_LIBADD =
+libgstqtdemux_la_LIBADD = $(GST_BASE_LIBS)
libgstqtdemux_la_LDFLAGS = ${GST_PLUGIN_LDFLAGS}
libgstqtdemux_la_SOURCES = qtdemux.c