summaryrefslogtreecommitdiffstats
path: root/gst/real/Makefile.am
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2007-01-05 18:15:52 +0000
committerEdward Hervey <bilboed@bilboed.com>2007-01-05 18:15:52 +0000
commit5b4a32581104b18d084ff97c65fa91afc653c487 (patch)
tree1d165b9bfe69f2eff2100381f87cb6cba727d578 /gst/real/Makefile.am
parentaf11eaab0c290e0e85b8dc442690f17a1b696ad1 (diff)
downloadgst-plugins-bad-5b4a32581104b18d084ff97c65fa91afc653c487.tar.gz
gst-plugins-bad-5b4a32581104b18d084ff97c65fa91afc653c487.tar.bz2
gst-plugins-bad-5b4a32581104b18d084ff97c65fa91afc653c487.zip
configure.ac: Real video .so are now also available for x86_64, so we can build the
Original commit message from CVS: * configure.ac: Real video .so are now also available for x86_64, so we can build the Real plugin on i386 AND x86_64. * gst/real/Makefile.am: * gst/real/gstreal.c: (plugin_init): New plugin file for real .so wrapper plugins. * gst/real/gstrealvideodec.c: (gst_real_video_dec_alloc_buffer), (gst_real_video_dec_decode), (gst_real_video_dec_chain), (gst_real_video_dec_activate_push), (gst_real_video_dec_setcaps), (open_library), (close_library), (gst_real_video_dec_init), (gst_real_video_dec_base_init), (gst_real_video_dec_finalize), (gst_real_video_dec_set_property), (gst_real_video_dec_get_property), (gst_real_video_dec_class_init): * gst/real/gstrealvideodec.h: Moved RealVideo element to separate file Cleaned up code some more. Make it work on x86_64. Try several possible locations for .so Separate opening/closing libraries in separate functions.
Diffstat (limited to 'gst/real/Makefile.am')
-rw-r--r--gst/real/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/gst/real/Makefile.am b/gst/real/Makefile.am
index d1d924c8..8096c579 100644
--- a/gst/real/Makefile.am
+++ b/gst/real/Makefile.am
@@ -1,7 +1,9 @@
plugin_LTLIBRARIES = libgstreal.la
-libgstreal_la_SOURCES = gstreal.c
+libgstreal_la_SOURCES = gstrealvideodec.c gstreal.c
libgstreal_la_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS)
libgstreal_la_LIBADD = $(GST_BASE_LIBS)
libgstreal_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstrealvideodec.h \ No newline at end of file