summaryrefslogtreecommitdiffstats
path: root/gst/vmnc/Makefile.am
diff options
context:
space:
mode:
authorMichael Smith <msmith@xiph.org>2007-03-03 22:13:22 +0000
committerMichael Smith <msmith@xiph.org>2007-03-03 22:13:22 +0000
commit1a428b03ed3ec854d9384b26dcdb8f1aba15a585 (patch)
tree4748608a0e7e9692b7eb031b0f4cd48f91cf83f5 /gst/vmnc/Makefile.am
parentd84dc3a4af877300e603ca2c65338577113de16a (diff)
downloadgst-plugins-bad-1a428b03ed3ec854d9384b26dcdb8f1aba15a585.tar.gz
gst-plugins-bad-1a428b03ed3ec854d9384b26dcdb8f1aba15a585.tar.bz2
gst-plugins-bad-1a428b03ed3ec854d9384b26dcdb8f1aba15a585.zip
Add VMnc decoder.
Original commit message from CVS: * configure.ac: * gst/vmnc/Makefile.am: * gst/vmnc/vmncdec.c: (gst_vmnc_dec_base_init), (gst_vmnc_dec_class_init), (gst_vmnc_dec_init), (gst_vmnc_dec_reset), (vmnc_handle_wmvi_rectangle), (render_colour_cursor), (render_cursor), (vmnc_make_buffer), (vmnc_handle_wmvd_rectangle), (vmnc_handle_wmve_rectangle), (vmnc_handle_wmvf_rectangle), (vmnc_handle_wmvg_rectangle), (vmnc_handle_wmvh_rectangle), (vmnc_handle_wmvj_rectangle), (render_raw_tile), (render_subrect), (vmnc_handle_raw_rectangle), (vmnc_handle_hextile_rectangle), (vmnc_handle_packet), (vmnc_dec_setcaps), (vmnc_dec_chain), (vmnc_dec_change_state), (vmnc_dec_set_property), (vmnc_dec_get_property), (plugin_init): Add VMnc decoder. Still missing support for: - rectangle types I didn't find in my samples (e.g. copy, RRE, ZRLE) - alpha-composited cursors
Diffstat (limited to 'gst/vmnc/Makefile.am')
-rw-r--r--gst/vmnc/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/gst/vmnc/Makefile.am b/gst/vmnc/Makefile.am
new file mode 100644
index 00000000..4c0fb328
--- /dev/null
+++ b/gst/vmnc/Makefile.am
@@ -0,0 +1,6 @@
+plugin_LTLIBRARIES = libgstvmware.la
+
+libgstvmware_la_SOURCES = vmncdec.c
+libgstvmware_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(THEORA_CFLAGS)
+libgstvmware_la_LIBADD = $(GST_LIBS)
+libgstvmware_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)