summaryrefslogtreecommitdiffstats
path: root/gst/xingheader/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <teuf@gnome.org>2006-03-11 11:12:30 +0000
committerChristophe Fergeau <teuf@gnome.org>2006-03-11 11:12:30 +0000
commitb9571c8b4605d77cd723a4ee0978fab55899bde8 (patch)
treec8b6f358ba4bdcfef429a10d7f63fd248c181c0d /gst/xingheader/Makefile.am
parenta1b0d326a7f4ef4287d77b6565df7841a6d091b4 (diff)
downloadgst-plugins-bad-b9571c8b4605d77cd723a4ee0978fab55899bde8.tar.gz
gst-plugins-bad-b9571c8b4605d77cd723a4ee0978fab55899bde8.tar.bz2
gst-plugins-bad-b9571c8b4605d77cd723a4ee0978fab55899bde8.zip
added new element to add Xing headers to MP3 files (this allows decoder to figure out the length of VBR files)
Original commit message from CVS: 2006-03-11 Christophe Fergeau <teuf@gnome.org> Reviewed by: Tim-Philipp Müller <tim at centricular dot net> * configure.ac: * gst/xingheader/Makefile.am: * gst/xingheader/gstxingmux.c: * gst/xingheader/gstxingmux.h: added new element to add Xing headers to MP3 files (this allows decoder to figure out the length of VBR files)
Diffstat (limited to 'gst/xingheader/Makefile.am')
-rw-r--r--gst/xingheader/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/gst/xingheader/Makefile.am b/gst/xingheader/Makefile.am
new file mode 100644
index 00000000..6719a1a3
--- /dev/null
+++ b/gst/xingheader/Makefile.am
@@ -0,0 +1,12 @@
+
+plugin_LTLIBRARIES = libgstxingheader.la
+
+libgstxingheader_la_SOURCES = gstxingmux.c
+libgstxingheader_la_CFLAGS = $(GST_CFLAGS)
+libgstxingheader_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+
+noinst_HEADERS = gstxingmux.h
+
+AM_CFLAGS = $(GST_CFLAGS)
+LIBS = $(GST_LIBS) $(LAME_LIBS)