summaryrefslogtreecommitdiffstats
path: root/pkgconfig/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2003-01-28 20:22:19 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2003-01-28 20:22:19 +0000
commit7786c9d322bc4790281ef7229f835cac8d7be3b7 (patch)
treef9da2f70c88f1b494e9596168d8c93b09bd5fe19 /pkgconfig/Makefile.am
parent7301a369eb4a57aa6ea9b8b96eb83b9d7a4d2a52 (diff)
downloadgst-plugins-bad-7786c9d322bc4790281ef7229f835cac8d7be3b7.tar.gz
gst-plugins-bad-7786c9d322bc4790281ef7229f835cac8d7be3b7.tar.bz2
gst-plugins-bad-7786c9d322bc4790281ef7229f835cac8d7be3b7.zip
pkg-config stuff
Original commit message from CVS: pkg-config stuff
Diffstat (limited to 'pkgconfig/Makefile.am')
-rw-r--r--pkgconfig/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
new file mode 100644
index 00000000..80f11af1
--- /dev/null
+++ b/pkgconfig/Makefile.am
@@ -0,0 +1,47 @@
+if USE_GCONF
+GCONF_PC=gstreamer-gconf-@GST_MAJORMINOR@.pc
+GCONF_PC_UNINSTALLED=gstreamer-gconf-@GST_MAJORMINOR@-uninstalled.pc
+else
+GCONF_PC=
+GCONF_PC_UNINSTALLED=
+endif
+
+### all of the standard pc files we need to generate
+pcfiles = \
+ gstreamer-libs-@GST_MAJORMINOR@.pc \
+ gstreamer-play-@GST_MAJORMINOR@.pc
+pcfiles_uninstalled = \
+ gstreamer-libs-@GST_MAJORMINOR@-uninstalled.pc \
+ gstreamer-play-@GST_MAJORMINOR@-uninstalled.pc
+
+all-local: $(pcfiles) $(pcfiles_uninstalled) \
+ $(GCONF_PC) \
+ $(GCONF_PC_UNINSTALLED) \
+ gst-element-check-@GST_MAJORMINOR@.m4
+
+### how to generate pc files
+$(pcfiles): %-@GST_MAJORMINOR@.pc: %.pc
+ cp $< $@
+$(pcfiles_uninstalled): %-@GST_MAJORMINOR@-uninstalled.pc: %-uninstalled.pc
+ cp $< $@
+
+gstreamer-gconf-@GST_MAJORMINOR@.pc: \
+ $(srcdir)/../gst-libs/gst/gconf/gstreamer-gconf.pc
+ cp $< $@
+gstreamer-gconf-@GST_MAJORMINOR@-uninstalled.pc: \
+ $(srcdir)/../gst-libs/gst/gconf/gstreamer-gconf-uninstalled.pc
+ cp $< $@
+
+gst-element-check-@GST_MAJORMINOR@.m4: gst-element-check.m4
+ cp $(srcdir)/gst-element-check.m4 gst-element-check-@GST_MAJORMINOR@.m4
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = \
+ $(GCONF_PC) \
+ gstreamer-libs-@GST_MAJORMINOR@.pc \
+ gstreamer-play-@GST_MAJORMINOR@.pc
+
+EXTRA_DIST= \
+ gstreamer-libs.pc.in gstreamer-libs-uninstalled.pc.in \
+ gstreamer-play.pc.in gstreamer-play-uninstalled.pc.in \
+ gstreamer-gconf.pc.in gstreamer-gconf.pc-uninstalled.in