summaryrefslogtreecommitdiffstats
path: root/sys/Makefile.am
diff options
context:
space:
mode:
authorJulien Moutte <julien@moutte.net>2007-11-26 13:19:48 +0000
committerJulien Moutte <julien@moutte.net>2007-11-26 13:19:48 +0000
commit307925e3077da26e33b06a6c53080ebf07328847 (patch)
treecaf4f0f031f18ed21b468e7343a1d6d59cf18b39 /sys/Makefile.am
parent5153aa15d468c838622f07426c0d4b86442872ae (diff)
downloadgst-plugins-bad-307925e3077da26e33b06a6c53080ebf07328847.tar.gz
gst-plugins-bad-307925e3077da26e33b06a6c53080ebf07328847.tar.bz2
gst-plugins-bad-307925e3077da26e33b06a6c53080ebf07328847.zip
configure.ac: Add QuickTime Wrapper plug-in.
Original commit message from CVS: 2007-11-26 Julien Moutte <julien@fluendo.com> * configure.ac: Add QuickTime Wrapper plug-in. * gst/speexresample/gstspeexresample.c: (gst_speex_resample_push_drain), (gst_speex_resample_process): Fix build on Mac OS X Leopard. Incorrect printf format arguments. * sys/Makefile.am: * sys/qtwrapper/Makefile.am: * sys/qtwrapper/audiodecoders.c: (qtwrapper_audio_decoder_base_init), (qtwrapper_audio_decoder_class_init), (qtwrapper_audio_decoder_init), (clear_AudioStreamBasicDescription), (fill_indesc_mp3), (fill_indesc_aac), (fill_indesc_samr), (fill_indesc_generic), (make_samr_magic_cookie), (open_decoder), (qtwrapper_audio_decoder_sink_setcaps), (process_buffer_cb), (qtwrapper_audio_decoder_chain), (qtwrapper_audio_decoder_sink_event), (qtwrapper_audio_decoders_register): * sys/qtwrapper/codecmapping.c: (audio_caps_from_string), (fourcc_to_caps): * sys/qtwrapper/codecmapping.h: * sys/qtwrapper/imagedescription.c: (image_description_for_avc1), (image_description_for_mp4v), (image_description_from_stsd_buffer), (image_description_from_codec_data): * sys/qtwrapper/imagedescription.h: * sys/qtwrapper/qtutils.c: (get_name_info_from_component), (get_output_info_from_component), (dump_avcc_atom), (dump_image_description), (dump_codec_decompress_params), (addSInt32ToDictionary), (dump_cvpixel_buffer), (DestroyAudioBufferList), (AllocateAudioBufferList): * sys/qtwrapper/qtutils.h: * sys/qtwrapper/qtwrapper.c: (plugin_init): * sys/qtwrapper/qtwrapper.h: * sys/qtwrapper/videodecoders.c: (qtwrapper_video_decoder_base_init), (qtwrapper_video_decoder_class_init), (qtwrapper_video_decoder_init), (qtwrapper_video_decoder_finalize), (fill_image_description), (new_image_description), (close_decoder), (open_decoder), (qtwrapper_video_decoder_sink_setcaps), (decompressCb), (qtwrapper_video_decoder_chain), (qtwrapper_video_decoder_sink_event), (qtwrapper_video_decoders_register): Initial import of QuickTime wrapper jointly developped by Songbird authors (Pioneers of the Inevitable) and Fluendo.
Diffstat (limited to 'sys/Makefile.am')
-rw-r--r--sys/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys/Makefile.am b/sys/Makefile.am
index 106c729c..564771eb 100644
--- a/sys/Makefile.am
+++ b/sys/Makefile.am
@@ -34,6 +34,12 @@ else
DVB_DIR=
endif
-SUBDIRS = $(GL_DIR) $(DVB_DIR) $(VCD_DIR)
+if USE_QUICKTIME
+QT_DIR=qtwrapper
+else
+QT_DIR=
+endif
+
+SUBDIRS = $(GL_DIR) $(DVB_DIR) $(VCD_DIR) $(QT_DIR)
-DIST_SUBDIRS = glsink dvb vcd
+DIST_SUBDIRS = glsink dvb vcd qtwrapper