summaryrefslogtreecommitdiffstats
path: root/sys/Makefile.am
diff options
context:
space:
mode:
authorVincent Torri <vtorri@univ-evry.fr>2007-01-03 19:54:33 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-01-03 19:54:33 +0000
commite163953b0e1c80aab8622cc0ec5ed567da8097c1 (patch)
tree44aab9ef7ea0673e97cb433f4853b910da9b9025 /sys/Makefile.am
parent9b1bffb45607c0cdfc80d1c856d331789789cd34 (diff)
downloadgst-plugins-bad-e163953b0e1c80aab8622cc0ec5ed567da8097c1.tar.gz
gst-plugins-bad-e163953b0e1c80aab8622cc0ec5ed567da8097c1.tar.bz2
gst-plugins-bad-e163953b0e1c80aab8622cc0ec5ed567da8097c1.zip
Add directdrawsink to build and dist it, so it gets built when compiling with MingW on win32 and the required headers...
Original commit message from CVS: Patch by: Vincent Torri <vtorri at univ-evry fr> * configure.ac: * sys/Makefile.am: * sys/directdraw/Makefile.am: Add directdrawsink to build and dist it, so it gets built when compiling with MingW on win32 and the required headers and libraries are available (fixes: #392313). * sys/directdraw/gstdirectdrawsink.c: (gst_directdrawsink_center_rect), (gst_directdrawsink_show_frame), (gst_directdrawsink_setup_ddraw), (gst_directdrawsink_surface_create): Comment out some unused things and fix some printf format issues in order to avoid warnings when buildling with MingW (#392313).
Diffstat (limited to 'sys/Makefile.am')
-rw-r--r--sys/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys/Makefile.am b/sys/Makefile.am
index 3866499c..66c97a31 100644
--- a/sys/Makefile.am
+++ b/sys/Makefile.am
@@ -34,6 +34,12 @@ else
DVB_DIR=
endif
-SUBDIRS = $(GL_DIR) $(DVB_DIR)
+if USE_DIRECTDRAW
+DIRECTDRAW_DIR=directdraw
+else
+DIRECTDRAW_DIR=
+endif
+
+SUBDIRS = $(GL_DIR) $(DVB_DIR) $(DIRECTDRAW_DIR)
-DIST_SUBDIRS = glsink dvb
+DIST_SUBDIRS = glsink dvb directdraw