summaryrefslogtreecommitdiffstats
path: root/sys/dxr3/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2004-06-24 01:43:55 +0000
committerBenjamin Otte <otte@gnome.org>2004-06-24 01:43:55 +0000
commit838bc540841852e032694814668aa436849e6f9d (patch)
treeb17c61d4705d6333aa8fb364f41962e0793f4154 /sys/dxr3/Makefile.am
parentbe7c1e4d8024f196265535ab18c3d71e8f9571ad (diff)
downloadgst-plugins-bad-838bc540841852e032694814668aa436849e6f9d.tar.gz
gst-plugins-bad-838bc540841852e032694814668aa436849e6f9d.tar.bz2
gst-plugins-bad-838bc540841852e032694814668aa436849e6f9d.zip
don't include -enumtypes.[ch] or -marshal.[ch] files in the disted tarball.
Original commit message from CVS: * gst-libs/gst/colorbalance/Makefile.am: * gst-libs/gst/mixer/Makefile.am: * gst-libs/gst/play/Makefile.am: * gst-libs/gst/tuner/Makefile.am: * gst/tcp/Makefile.am: * sys/dxr3/Makefile.am: don't include -enumtypes.[ch] or -marshal.[ch] files in the disted tarball. Also add all *.list files that were missing. * Makefile.am: add a distcheck hook to ensure the above doesn't happen again.
Diffstat (limited to 'sys/dxr3/Makefile.am')
-rw-r--r--sys/dxr3/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys/dxr3/Makefile.am b/sys/dxr3/Makefile.am
index 071fc367..3968db3e 100644
--- a/sys/dxr3/Makefile.am
+++ b/sys/dxr3/Makefile.am
@@ -2,7 +2,8 @@
plugin_LTLIBRARIES = libgstdxr3.la
libgstdxr3_la_SOURCES = dxr3videosink.c dxr3audiosink.c dxr3spusink.c \
- dxr3init.c ac3_padder.c dxr3marshal.c
+ dxr3init.c ac3_padder.c
+noinst_libgstdxr3_la_SOURCES = dxr3marshal.c
libgstdxr3_la_CFLAGS = $(GST_CFLAGS)
libgstdxr3_la_LIBADD =
libgstdxr3_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
@@ -25,3 +26,4 @@ dxr3marshal.c: dxr3marshal.list
glib-genmarshal --body --prefix=dxr3_marshal $^ >> dxr3marshal.c.tmp
mv dxr3marshal.c.tmp dxr3marshal.c
+CLEANFILES = $(BUILT_SOURCES)