summaryrefslogtreecommitdiffstats
path: root/sys/glsink/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2007-12-27 00:52:23 +0000
committerDavid Schleef <ds@schleef.org>2007-12-27 00:52:23 +0000
commit3b15f24af01272a011b9e8d9df500a7c62eb496d (patch)
tree91291cff718e109a715332794c0f575786555121 /sys/glsink/Makefile.am
parent28eec0700150e32a4f257985a53c22ab22cf562f (diff)
downloadgst-plugins-bad-3b15f24af01272a011b9e8d9df500a7c62eb496d.tar.gz
gst-plugins-bad-3b15f24af01272a011b9e8d9df500a7c62eb496d.tar.bz2
gst-plugins-bad-3b15f24af01272a011b9e8d9df500a7c62eb496d.zip
sys/glsink/: Remove code that handles non-texture buffers. Add a
Original commit message from CVS: * sys/glsink/BUGS: * sys/glsink/Makefile.am: * sys/glsink/gstglbuffer.c: * sys/glsink/gstglbuffer.h: * sys/glsink/gstglconvert.c: * sys/glsink/gstgldisplay.c: * sys/glsink/gstglfilter.c: * sys/glsink/gstglfilter.h: * sys/glsink/gstglfilterexample.c: * sys/glsink/gstgltestsrc.c: * sys/glsink/gstglupload.c: * sys/glsink/gstopengl.c: Remove code that handles non-texture buffers. Add a GstGLBufferFormat type that corresponds to how to use the texture, not the original video format. Convert gstflfilter.c into a base class, add glfilterexample and glconvert elements. * sys/glsink/color_matrix.c: Minor ramblings about color conversion matrices.
Diffstat (limited to 'sys/glsink/Makefile.am')
-rw-r--r--sys/glsink/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/sys/glsink/Makefile.am b/sys/glsink/Makefile.am
index b4f72c92..6cb9dd10 100644
--- a/sys/glsink/Makefile.am
+++ b/sys/glsink/Makefile.am
@@ -1,6 +1,11 @@
plugin_LTLIBRARIES = libgstglimagesink.la
+noinst_PROGRAMS = color_matrix
+
+AM_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS)
+AM_LIBS = $(GST_BASE_LIBS)
+
libgstglimagesink_la_SOURCES = \
glimagesink.c \
gstgldisplay.c \
@@ -11,7 +16,9 @@ libgstglimagesink_la_SOURCES = \
gstgldownload.c \
gstgltestsrc.c \
gltestsrc.c \
- gstglfilter.c
+ gstglfilter.c \
+ gstglfilterexample.c \
+ gstglconvert.c
libgstglimagesink_la_CFLAGS = $(GST_CFLAGS) $(X_CFLAGS) $(GST_BASE_CFLAGS) \
$(GST_PLUGINS_BASE_CFLAGS)
libgstglimagesink_la_LIBADD = $(X_LIBS) $(XSHM_LIBS) -lGL \
@@ -25,4 +32,5 @@ noinst_HEADERS = \
glextensions.h \
gstgltestsrc.h \
gltestsrc.h \
- gstglbuffer.h
+ gstglbuffer.h \
+ gstglfilter.h