summaryrefslogtreecommitdiffstats
path: root/sys/osxvideo/Makefile.am
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2007-01-30 17:19:33 +0000
committerEdward Hervey <bilboed@bilboed.com>2007-01-30 17:19:33 +0000
commit385bba644fffe6d585467a34ac8e01563263f4b5 (patch)
tree4bedc4db2b677228da2b34bacc43558e60e43563 /sys/osxvideo/Makefile.am
parent3838fe023eaf04917356e6db8ce548b16538d0db (diff)
downloadgst-plugins-bad-385bba644fffe6d585467a34ac8e01563263f4b5.tar.gz
gst-plugins-bad-385bba644fffe6d585467a34ac8e01563263f4b5.tar.bz2
gst-plugins-bad-385bba644fffe6d585467a34ac8e01563263f4b5.zip
configure.ac: Check for an Objective C compiler
Original commit message from CVS: * configure.ac: Check for an Objective C compiler * sys/Makefile.am: * sys/osxvideo/Makefile.am: * sys/osxvideo/cocoawindow.h: * sys/osxvideo/cocoawindow.m: * sys/osxvideo/osxvideosink.h: * sys/osxvideo/osxvideosink.m: Port of osxvideo plugin to 0.10. Do NOT consider 100% stable ! Fixes #402470
Diffstat (limited to 'sys/osxvideo/Makefile.am')
-rw-r--r--sys/osxvideo/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/sys/osxvideo/Makefile.am b/sys/osxvideo/Makefile.am
new file mode 100644
index 00000000..99bb0489
--- /dev/null
+++ b/sys/osxvideo/Makefile.am
@@ -0,0 +1,17 @@
+# FIXME: clean up this crap
+OBJC=gcc
+
+plugin_LTLIBRARIES = libgstosxvideosink.la
+
+libgstosxvideosink_la_SOURCES = osxvideosink.m cocoawindow.m
+libgstosxvideosink_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS)
+libgstosxvideosink_la_LIBADD = \
+ $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_MAJORMINOR) \
+ -lgstinterfaces-$(GST_MAJORMINOR)
+
+libgstosxvideosink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -Wl,-framework -Wl,Cocoa -Wl,-framework -Wl,QuickTime -Wl,-framework -Wl,OpenGL
+
+AM_OBJCFLAGS=$(CFLAGS) $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS)
+
+noinst_HEADERS = osxvideosink.h cocoawindow.h