summaryrefslogtreecommitdiffstats
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2006-09-02 18:49:01 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-09-02 18:49:01 +0000
commitacba8c1dbdc547b595f8e632f1a89d305e7d0a7f (patch)
treee535bad71d6abbf2fa05ae4555ee59222b76a821 /tests/check/Makefile.am
parent7e69aee2235e401680ca441a449e6b741e8c5837 (diff)
downloadgst-plugins-bad-acba8c1dbdc547b595f8e632f1a89d305e7d0a7f.tar.gz
gst-plugins-bad-acba8c1dbdc547b595f8e632f1a89d305e7d0a7f.tar.bz2
gst-plugins-bad-acba8c1dbdc547b595f8e632f1a89d305e7d0a7f.zip
docs/plugins/: Add videocrop to docs.
Original commit message from CVS: * docs/plugins/Makefile.am: * docs/plugins/gst-plugins-bad-plugins-docs.sgml: * docs/plugins/gst-plugins-bad-plugins-sections.txt: * docs/plugins/gst-plugins-bad-plugins.hierarchy: Add videocrop to docs. * gst/videocrop/Makefile.am: * gst/videocrop/gstvideocrop.c: * gst/videocrop/gstvideocrop.h: Move boilerplate stuff and structures into a header file. * tests/check/Makefile.am: * tests/check/elements/.cvsignore: * tests/check/elements/videocrop.c: (video_crop_get_test_caps), (test_unit_sizes), (videocrop_test_cropping_init_context), (videocrop_test_cropping_deinit_context), (videocrop_test_cropping), (test_cropping), (videocrop_suite): Add unit tests for videocrop.
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index e85d5c8b..11056b4d 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -45,13 +45,21 @@ VALGRIND_TO_FIX = \
elements/mpeg2enc
# valgrind testing
-VALGRIND_TESTS_DISABLE = $(VALGRIND_TO_FIX)
+# videocrop disabled since it takes way too long in valgrind
+VALGRIND_TESTS_DISABLE = \
+ elements/videocrop \
+ $(VALGRIND_TO_FIX)
check_PROGRAMS = \
- $(check_mpeg2enc) \
+ $(check_mpeg2enc) \
+ elements/videocrop \
$(check_wavpack)
TESTS = $(check_PROGRAMS)
AM_CFLAGS = $(GST_OBJ_CFLAGS) $(GST_CHECK_CFLAGS) $(CHECK_CFLAGS)
LDADD = $(GST_OBJ_LIBS) $(GST_CHECK_LIBS) $(CHECK_LIBS)
+
+
+elements_videocrop_LDADD = $(LDADD) $(GST_BASE_LIBS)
+elements_videocrop_CFLAGS = $(CFLAGS) $(AM_CFLAGS) $(GST_BASE_CFLAGS)