summaryrefslogtreecommitdiffstats
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2006-05-22 13:25:52 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2006-05-22 13:25:52 +0000
commitd3c823f87746363b235f1b374eac1e4b41d7bf57 (patch)
tree8f6345ffee69b114d90f6e4c69686a582de754a3 /tests/check/Makefile.am
parentd440cf33c64500495623c5aecc2ed226dcb3a075 (diff)
downloadgst-plugins-bad-d3c823f87746363b235f1b374eac1e4b41d7bf57.tar.gz
gst-plugins-bad-d3c823f87746363b235f1b374eac1e4b41d7bf57.tar.bz2
gst-plugins-bad-d3c823f87746363b235f1b374eac1e4b41d7bf57.zip
adding GDP payloader and depayloader. Build integration will follow later when the GDP issues for core are sorted out.
Original commit message from CVS: * gst/gdp/Makefile.am: * gst/gdp/gstgdp.c: (plugin_init): * gst/gdp/gstgdpdepay.c: (gst_gdp_depay_base_init), (gst_gdp_depay_class_init), (gst_gdp_depay_init), (gst_gdp_depay_finalize), (gst_gdp_depay_chain), (gst_gdp_depay_change_state), (gst_gdp_depay_plugin_init): * gst/gdp/gstgdpdepay.h: * gst/gdp/gstgdppay.c: (gst_gdp_pay_base_init), (gst_gdp_pay_class_init), (gst_gdp_pay_init), (gst_gdp_pay_dispose), (gst_gdp_stamp_buffer), (gst_gdp_buffer_from_caps), (gst_gdp_pay_buffer_from_buffer), (gst_gdp_buffer_from_event), (gst_gdp_pay_reset_streamheader), (gst_gdp_queue_buffer), (gst_gdp_pay_chain), (gst_gdp_pay_sink_event), (gst_gdp_pay_change_state), (gst_gdp_pay_plugin_init): * gst/gdp/gstgdppay.h: * tests/check/Makefile.am: * tests/check/elements/gdpdepay.c: (setup_gdpdepay), (cleanup_gdpdepay), (gdpdepay_push_per_byte), (GST_START_TEST), (setup_gdpdepay_streamheader), (gdpdepay_suite), (main): * tests/check/elements/gdppay.c: (setup_gdppay), (cleanup_gdppay), (GST_START_TEST), (setup_gdppay_streamheader), (gdppay_suite), (main): adding GDP payloader and depayloader. Build integration will follow later when the GDP issues for core are sorted out.
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index c1663887..96df1978 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -12,7 +12,7 @@ REGISTRY_ENVIRONMENT = \
TESTS_ENVIRONMENT = \
$(REGISTRY_ENVIRONMENT) \
GST_PLUGIN_SYSTEM_PATH= \
- GST_PLUGIN_PATH=$(top_builddir)/ext:$(GSTPB_PLUGINS_DIR)/../gst-plugins-good:$(GSTPB_PLUGINS_DIR):$(GST_PLUGINS_DIR)
+ GST_PLUGIN_PATH=$(top_builddir)/gst:$(top_builddir)/ext:$(GSTPB_PLUGINS_DIR):$(GST_PLUGINS_DIR)
plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
@@ -26,9 +26,13 @@ SUPPRESSIONS = $(top_srcdir)/common/gst.supp
clean-local: clean-local-check
-check_PROGRAMS =
+check_PROGRAMS = \
+ elements/gdppay \
+ elements/gdpdepay
TESTS = $(check_PROGRAMS)
AM_CFLAGS = $(GST_OBJ_CFLAGS) $(GST_CHECK_CFLAGS) $(CHECK_CFLAGS)
LDADD = $(GST_OBJ_LIBS) $(GST_CHECK_LIBS) $(CHECK_LIBS)
+
+elements_gdpdepay_LDFLAGS = $(LDADD) $(GST_GDP_LIBS)