summaryrefslogtreecommitdiffstats
path: root/tests/icles/Makefile.am
diff options
context:
space:
mode:
authorWouter Paesen <wouter@kangaroot.net>2006-06-14 18:07:51 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-06-14 18:07:51 +0000
commit34f03fe525ac9c9e646ac77b9b0b655bd46d433b (patch)
tree9fc3d837bc70e7ffc468e796146c5620499e53e9 /tests/icles/Makefile.am
parentbed0b905a19551aa9cfec0dcfd1f744c1576c5a1 (diff)
downloadgst-plugins-bad-34f03fe525ac9c9e646ac77b9b0b655bd46d433b.tar.gz
gst-plugins-bad-34f03fe525ac9c9e646ac77b9b0b655bd46d433b.tar.bz2
gst-plugins-bad-34f03fe525ac9c9e646ac77b9b0b655bd46d433b.zip
ext/soundtouch/: Make pitch element controllable via GstController interface (#344821).
Original commit message from CVS: Patch by: Wouter Paesen <wouter at kangaroot net> * ext/soundtouch/Makefile.am: * ext/soundtouch/gstpitch.cc: Make pitch element controllable via GstController interface (#344821). * configure.ac: Up core requirements to 0.10.8.1/CVS because earlier GstControllers can't handle float properties correctly. Check for GstController CFLAGS and LIBS. * tests/icles/Makefile.am: * tests/icles/pitch-test.c: (main): Add small test program for the above (welcome to the 80s!).
Diffstat (limited to 'tests/icles/Makefile.am')
-rw-r--r--tests/icles/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/tests/icles/Makefile.am b/tests/icles/Makefile.am
index e3018d30..e1920fd2 100644
--- a/tests/icles/Makefile.am
+++ b/tests/icles/Makefile.am
@@ -12,5 +12,18 @@ else
GST_V4L2_TESTS =
endif
-noinst_PROGRAMS = $(GST_V4L2_TESTS)
+if USE_SOUNDTOUCH
+
+GST_SOUNDTOUCH_TESTS = pitch-test
+
+pitch_test_SOURCES = pitch-test.c
+pitch_test_CFLAGS = $(GST_CONTROLLER_CFLAGS)
+pitch_test_LDADD = $(GST_CONTROLLER_LIBS)
+pitch_test_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+else
+GST_SOUNDTOUCH_TESTS =
+endif
+
+noinst_PROGRAMS = $(GST_V4L2_TESTS) $(GST_SOUNDTOUCH_TESTS)