summaryrefslogtreecommitdiffstats
path: root/tests/icles/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2008-01-26 12:11:47 +0000
committerTim-Philipp Müller <tim@centricular.net>2008-01-26 12:11:47 +0000
commit3a5db6a93221b15b23ae593d55f3cdc7e4f2804a (patch)
tree28a3efcfb09495be3808e0ffc86311d1def62582 /tests/icles/Makefile.am
parent9e31b57dc37cb94761ab3aa98018c6f9bc496e0c (diff)
downloadgst-plugins-bad-3a5db6a93221b15b23ae593d55f3cdc7e4f2804a.tar.gz
gst-plugins-bad-3a5db6a93221b15b23ae593d55f3cdc7e4f2804a.tar.bz2
gst-plugins-bad-3a5db6a93221b15b23ae593d55f3cdc7e4f2804a.zip
configure.ac: Check for libglade-2.0, for the metadata-editor example.
Original commit message from CVS: * configure.ac: Check for libglade-2.0, for the metadata-editor example. * tests/icles/Makefile.am: Only try to build the metadata-editor example if we have gtk and glade (otherwise the build would just fail ...); fix build in uninstalled setup. * tests/icles/metadata_editor.c: (on_cell_edited), (ui_add_columns): Fix compiler warnings (use GLib macros to cast pointer <-> int).
Diffstat (limited to 'tests/icles/Makefile.am')
-rw-r--r--tests/icles/Makefile.am21
1 files changed, 13 insertions, 8 deletions
diff --git a/tests/icles/Makefile.am b/tests/icles/Makefile.am
index 26a5453a..b3fba24c 100644
--- a/tests/icles/Makefile.am
+++ b/tests/icles/Makefile.am
@@ -12,18 +12,23 @@ GST_SOUNDTOUCH_TESTS =
endif
if USE_METADATA
+if HAVE_GLADE
+if HAVE_GTK
GST_METADATA_TESTS = metadata_editor
metadata_editor_SOURCES = metadata_editor.c
-metadata_editor_CFLAGS = $(GST_CFLAGS) \
- `pkg-config --cflags gstreamer-0.10 libglade-2.0 gtk+-2.0`
-metadata_editor_LDADD = $(GST_LIBS)
-metadata_editor_LDFLAGS = $(GST_PLUGIN_LDFLAGS) \
- -Wl -export-dynamic \
- -lgstinterfaces-0.10 \
- `pkg-config --libs gstreamer-0.10 libglade-2.0 gtk+-2.0`
-
+metadata_editor_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(GLADE_CFLAGS)
+metadata_editor_LDADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgstinterfaces-0.10 $(GST_LIBS) $(GLADE_LIBS)
+metadata_editor_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+else
+GST_METADATA_TESTS =
+endif
+else
+GST_METADATA_TESTS =
+endif
else
GST_METADATA_TESTS =
endif