summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bc13b65a..58c2c379 100644
--- a/configure.ac
+++ b/configure.ac
@@ -420,8 +420,13 @@ AG_GST_CHECK_FEATURE(DIRECTFB, [directfb], dfbvideosink , [
dnl *** DTS ***
translit(dnm, m, l) AM_CONDITIONAL(USE_DTS, true)
AG_GST_CHECK_FEATURE(DTS, [dts library], dtsdec, [
+ HAVE_DTS="yes"
AG_GST_CHECK_LIBHEADER(DTS, dts_pic, dts_init, -lm, dts.h,
- DTS_LIBS="-ldts_pic -lm")
+ DTS_LIBS="-ldts_pic -lm", HAVE_DTS="no")
+ if test $HAVE_DTS = "no"; then
+ AG_GST_CHECK_LIBHEADER(DTS, dca, dca_init, -lm, dts.h,
+ DTS_LIBS="-ldca -lm")
+ fi
AC_SUBST(DTS_LIBS)
])