summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb52edb6..7a1bcd8e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -225,6 +225,12 @@ if test "x$HAVE_CXX" != "xyes"; then
AC_MSG_WARN([Not compiling plug-ins requiring C++ compiler])
GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | sed 's/modplug//g'`
fi
+
+dnl real plugin only works on 32bit x86 for the time being.
+if test "x$HAVE_CPU_I386" != "xyes" || test "xHAVE_CPU_X86_64" = "xyes"; then
+ AC_MSG_WARN([Not building real plugin, only works on 32bit x86 platforms])
+ GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | sed 's/real//g'`
+fi
AC_SUBST(GST_PLUGINS_SELECTED)