summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2685b26c..74aed820 100644
--- a/configure.ac
+++ b/configure.ac
@@ -259,6 +259,9 @@ AC_PATH_XTRA
if test "-DX_DISPLAY_MISSING" = "$X_CFLAGS"; then
AC_MSG_NOTICE([cannot find X11, the build system needs fixage])
fi
+dnl AC_PATH_XTRA only defines the path needed to find the X libs, not the libs
+dnl therefore we add them here
+X_LIBS="$X_LIBS -lX11"
AC_SUBST(X_CFLAGS)
AC_SUBST(X_PRE_LIBS)
AC_SUBST(X_EXTRA_LIBS)