summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bea6e4ab..d8fe94ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -190,6 +190,12 @@ dnl ============================= sys plugins ================================
dnl ==========================================================================
+dnl *** DXR3 card ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_DXR3, true)
+GST_CHECK_FEATURE(DXR3, [DXR3 hardware mpeg video decoder], dxr3videosink, [
+ AC_CHECK_HEADER(linux/em8000.h, HAVE_DXR3="yes", HAVE_DXR3="no")
+])
+
dnl *** OSS audio ***
translit(dnm, m, l) AM_CONDITIONAL(USE_OSS, true)
GST_CHECK_FEATURE(OSS, [OSS audio], osssrc osssink, [
@@ -762,6 +768,7 @@ gst/vumeter/Makefile
gst/wavparse/Makefile
gst/y4m/Makefile
sys/Makefile
+sys/dxr3/Makefile
sys/oss/Makefile
sys/qcam/Makefile
sys/v4l/Makefile