summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3d9c6835..0e53f53a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -324,6 +324,18 @@ dnl ###########################
dnl # Configure external libs #
dnl ###########################
+dnl **** DirectFB ****
+translit(dnm, m, l) AM_CONDITIONAL(USE_DIRECTFB, true)
+GST_CHECK_FEATURE(DIRECTFB, [directfb], dfbvideosink , [
+ PKG_CHECK_MODULES(DIRECTFB, directfb, [
+ HAVE_DIRECTFB="yes"
+ AC_SUBST(DIRECTFB_CFLAGS)
+ AC_SUBST(DIRECTFB_LIBS)
+ ], [
+ HAVE_DIRECTFB="no"
+ ])
+])
+
dnl **** Free AAC Encoder (FAAC) ****
translit(dnm, m, l) AM_CONDITIONAL(USE_FAAC, true)
GST_CHECK_FEATURE(FAAC, [AAC encoder plug-in], faac, [
@@ -470,6 +482,7 @@ gst/qtdemux/Makefile
gst/tta/Makefile
sys/Makefile
ext/Makefile
+ext/directfb/Makefile
ext/faac/Makefile
ext/faad/Makefile
ext/gsm/Makefile