summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 42396ec0..84cad0ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -602,6 +602,10 @@ GST_CHECK_FEATURE(FFMPEG, [ffmpeg plug-ins], ffmpeg, [
HAVE_FFMPEG=yes, HAVE_FFMPEG=no)
fi
fi
+ # ffmpeg requires gcc
+ if test "x$GCC" != xyes ; then
+ HAVE_FFMPEG=no
+ fi
# we only bother with uninstalled (included) ffmpeg for now
AC_DEFINE_UNQUOTED(HAVE_FFMPEG_UNINSTALLED, 1,
[defined if we use uninstalled ffmpeg])