summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4ae65d84..6e8231c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -601,6 +601,22 @@ GST_CHECK_FEATURE(HTTP, [http plug-ins], gsthttpsrc, [
AC_SUBST(GST_HTTPSRC_GET_TYPE)
])
+dnl *** ivorbis ***
+dnl AM_PATH_IVORBIS only takes two options
+translit(dnm, m, l) AM_CONDITIONAL(USE_IVORBIS, true)
+GST_CHECK_FEATURE(IVORBIS, [integer vorbis plug-in], ivorbisdec, [
+ XIPH_PATH_IVORBIS(HAVE_IVORBIS=yes, HAVE_IVORBIS=no)
+ AS_SCRUB_INCLUDE(IVORBIS_CFLAGS)
+])
+
+dnl *** ivorbis ***
+dnl AM_PATH_IVORBIS only takes two options
+translit(dnm, m, l) AM_CONDITIONAL(USE_IVORBIS, true)
+GST_CHECK_FEATURE(IVORBIS, [integer vorbis plug-in], ivorbisdec, [
+ XIPH_PATH_IVORBIS(HAVE_IVORBIS=yes, HAVE_IVORBIS=no)
+ AS_SCRUB_INCLUDE(IVORBIS_CFLAGS)
+])
+
dnl *** Jack ***
translit(dnm, m, l) AM_CONDITIONAL(USE_JACK, true)
GST_CHECK_FEATURE(JACK, Jack, jack, [
@@ -1098,6 +1114,7 @@ ext/gnomevfs/Makefile
ext/gsm/Makefile
ext/hermes/Makefile
ext/http/Makefile
+ext/ivorbis/Makefile
ext/jack/Makefile
ext/jpeg/Makefile
ext/ladspa/Makefile