summaryrefslogtreecommitdiffstats
path: root/examples/gob/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/gob/Makefile.am')
-rw-r--r--examples/gob/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/gob/Makefile.am b/examples/gob/Makefile.am
new file mode 100644
index 00000000..bd0b916e
--- /dev/null
+++ b/examples/gob/Makefile.am
@@ -0,0 +1,21 @@
+
+plugindir = $(libdir)/gst
+
+plugin_LTLIBRARIES = libgstidentity2.la
+
+GOB_FILES_ID = gst-identity2.c gst-identity2.h gst-identity2-private.h
+
+BUILT_SOURCES = \
+ $(GOB_FILES_ID)
+
+libgstidentity2_la_SOURCES = gst-identity2.gob $(GOB_FILES_ID)
+libgstidentity2_la_CFLAGS = $(GST_CFLAGS)
+libgstidentity2_la_LIBADD = $(GST_LIBS)
+
+%.c %.h %-private.h: %.gob
+ gob $<
+
+CLEANFILES = $(GOB_FILES_ID)
+
+dist-hook:
+ cd $(distdir); rm -f $(CLEANFILES)