summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 2b2aca01..ff91846e 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -10,6 +10,12 @@ else
AALIB_DIR=
endif
+if USE_ALSA
+ALSA_DIR=alsa
+else
+ALSA_DIR=
+endif
+
if USE_AUDIOFILE
AUDIOFILE_DIR=audiofile
else
@@ -47,8 +53,8 @@ VORBIS_DIR=
endif
-SUBDIRS=$(A52_DIR) $(AALIB_DIR) $(AUDIOFILE_DIR) $(ESD_DIR) \
+SUBDIRS=$(A52_DIR) $(AALIB_DIR) $(ALSA_DIR) $(AUDIOFILE_DIR) $(ESD_DIR) \
$(LAME_DIR) $(MAD_DIR) \
$(SDL_DIR) $(VORBIS_DIR)
-DIST_SUBDIRS=a52 aalib audiofile esd lame mad sdl vorbis
+DIST_SUBDIRS=a52 aalib alsa audiofile esd lame mad sdl vorbis