summaryrefslogtreecommitdiffstats
path: root/ext/alsaspdif/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/alsaspdif/Makefile.am')
-rw-r--r--ext/alsaspdif/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/ext/alsaspdif/Makefile.am b/ext/alsaspdif/Makefile.am
new file mode 100644
index 00000000..77bd3c62
--- /dev/null
+++ b/ext/alsaspdif/Makefile.am
@@ -0,0 +1,14 @@
+plugin_LTLIBRARIES = libgstalsaspdif.la
+
+# sources used to compile this plugin
+libgstalsaspdif_la_SOURCES = alsaspdifsink.c
+
+# flags used to compile this plugin
+# we use the GST_LIBS flags because we might be using plug-in libs
+libgstalsaspdif_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(ALSA_CFLAGS)
+libgstalsaspdif_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) $(GST_BASE_LIBS) $(GST_BASE_LIBS) $(GST_LIBS) $(ALSA_LIBS)
+libgstalsaspdif_la_LDFLAGS = $(GST_BASE_LIBS) $(GST_PLUGIN_LDFLAGS)
+
+# headers we need but don't want installed
+noinst_HEADERS = alsaspdifsink.h
+