summaryrefslogtreecommitdiffstats
path: root/ext/amrwb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/amrwb/Makefile.am')
-rw-r--r--ext/amrwb/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/ext/amrwb/Makefile.am b/ext/amrwb/Makefile.am
new file mode 100644
index 00000000..3efa09d8
--- /dev/null
+++ b/ext/amrwb/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS = amrwb-code
+plugin_LTLIBRARIES = libgstamrwb.la
+
+libgstamrwb_la_SOURCES = \
+ gstamrwb.c \
+ gstamrwbdec.c \
+ gstamrwbenc.c \
+ gstamrwbparse.c
+
+libgstamrwb_la_CFLAGS = $(GST_CFLAGS) $(AMRWB_CFLAGS) -Iamrwb-code/
+libgstamrwb_la_LIBADD = $(GST_BASE_LIBS) $(AMRWB_LIBS) amrwb-code/libamrwb.la
+libgstamrwb_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = \
+ gstamrwbdec.h \
+ gstamrwbenc.h \
+ gstamrwbparse.h
+